summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-08-03 12:26:32 +0200
committerStefano Karapetsas <[email protected]>2012-08-03 12:26:32 +0200
commit2d7e34441f4d33dc1edb5e9871b66b4977069bae (patch)
treeba425475d77dcca3c86c22b13db0b44ba4912bd9 /data/Makefile.am
parent597a9064e4d2df85d53726928e576a9be53d22fb (diff)
downloadmate-notification-daemon-2d7e34441f4d33dc1edb5e9871b66b4977069bae.tar.bz2
mate-notification-daemon-2d7e34441f4d33dc1edb5e9871b66b4977069bae.tar.xz
migrate to GSettings
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am19
1 files changed, 3 insertions, 16 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 4a80715..32e1d94 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -16,21 +16,11 @@ iconscalable_DATA = icons/scalable/mate-notification-properties.svg
servicedir = $(DBUS_SERVICES_DIR)
service_DATA = org.freedesktop.mate.Notifications.service
-schemasdir = $(MATECONF_SCHEMA_FILE_DIR)
-schemas_in_files = mate-notification-daemon.schemas.in
-schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
-
-@INTLTOOL_SCHEMAS_RULE@
-
-if MATECONF_SCHEMAS_INSTALL
-install-data-local:
- MATECONF_CONFIG_SOURCE=$(MATECONF_SCHEMA_CONFIG_SOURCE) $(MATECONFTOOL) --makefile-install-rule $(schemas_DATA)
-else
-install-data-local:
-endif
+gsettings_SCHEMAS = org.mate.NotificationDaemon.gschema.xml
+@GSETTINGS_RULES@
EXTRA_DIST = \
- $(schemas_in_files) \
+ $(gsettings_SCHEMAS) \
$(service_DATA) \
$(icon16_DATA) \
$(icon22_DATA) \
@@ -39,9 +29,6 @@ EXTRA_DIST = \
$(icon48_DATA) \
$(iconscalable_DATA)
-CLEANFILES = $(schemas_DATA)
-
-
gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
install-data-hook: update-icon-cache