summaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2019-10-10 20:21:39 +0200
committerraveit65 <[email protected]>2019-10-11 17:09:43 +0200
commit1f714672693f637f81ac55cf4f4618c74d10e229 (patch)
tree4b0608984141ac3918fde87e64eea77983a5ff86 /src/daemon/Makefile.am
parent2aa513e98b1e3ab11a8ed8b3421cc47780f62101 (diff)
downloadmate-notification-daemon-1f714672693f637f81ac55cf4f4618c74d10e229.tar.bz2
mate-notification-daemon-1f714672693f637f81ac55cf4f4618c74d10e229.tar.xz
Use WARN_CFLAGS which are only set with --enable-compiler-warnings
It removes --enable-more-warnings, since it is recommended to use --enable-compile-warnings=maximum It updates configure summary. It removes c++ checks as there is no c++ code.
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index db1f6be..179e964 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -14,6 +14,8 @@ mate_notification_daemon_SOURCES = \
mate_notification_daemon_LDADD = $(NOTIFICATION_DAEMON_LIBS)
+mate_notification_daemon_CFLAGS = $(WARN_CFLAGS)
+
mate_notification_daemon_built_sources = \
mnd-dbus-generated.h \
mnd-dbus-generated.c \