summaryrefslogtreecommitdiff
path: root/applets/clock/Makefile.am
diff options
context:
space:
mode:
authorLuke from DC <[email protected]>2023-07-11 10:02:50 +0000
committerGitHub <[email protected]>2023-07-11 12:02:50 +0200
commite8cd95789810bc9efb7961f553e99f0c2eaa0cd0 (patch)
tree4db4ceaaee315f1cd9bf68cb84c6ad8aeb8bf1ba /applets/clock/Makefile.am
parent5a7f770082568453f3a5f271a274156f08352101 (diff)
downloadmate-panel-e8cd95789810bc9efb7961f553e99f0c2eaa0cd0.tar.bz2
mate-panel-e8cd95789810bc9efb7961f553e99f0c2eaa0cd0.tar.xz
Clock applet/wayland: position calendar window same as in x11
* Clock applet/wayland: position calendar window same as in x11 - Wayland/clock: fix calendar window rendering when moved Ensure the calendar window cannot be "stretched" across the screen if the panel or the applet is moved while the calendar is showing
Diffstat (limited to 'applets/clock/Makefile.am')
-rw-r--r--applets/clock/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/applets/clock/Makefile.am b/applets/clock/Makefile.am
index c452fab9..e145dd5f 100644
--- a/applets/clock/Makefile.am
+++ b/applets/clock/Makefile.am
@@ -67,6 +67,14 @@ libclock_applet_la_LIBADD = $(CLOCK_LDADD)
libclock_applet_la_LDFLAGS = -module -avoid-version
libclock_applet_la_CFLAGS = $(AM_CFLAGS)
$(libclock_applet_la_OBJECTS): $(BUILT_SOURCES)
+
+if ENABLE_WAYLAND
+libclock_applet_la_LIBADD += \
+ $(WAYLAND_LIBS)
+
+AM_CPPFLAGS += \
+ $(WAYLAND_CFLAGS)
+endif
else
APPLET_IN_PROCESS = false
APPLET_LOCATION = $(libexecdir)/clock-applet