summaryrefslogtreecommitdiff
path: root/applets/fish/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-06 16:20:20 +0200
committerinfirit <[email protected]>2015-09-06 16:20:20 +0200
commit9ef7e261d4a9ea536d6f467c2b9bd1381bcd73aa (patch)
treee7e9ceb6ea268edfb47c900fd1a427f72059f9bc /applets/fish/Makefile.am
parent667466775b7d785ac048732b18efacea09711ab2 (diff)
downloadmate-panel-9ef7e261d4a9ea536d6f467c2b9bd1381bcd73aa.tar.bz2
mate-panel-9ef7e261d4a9ea536d6f467c2b9bd1381bcd73aa.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files
Diffstat (limited to 'applets/fish/Makefile.am')
-rw-r--r--applets/fish/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/applets/fish/Makefile.am b/applets/fish/Makefile.am
index f8688bac..7f63cf5f 100644
--- a/applets/fish/Makefile.am
+++ b/applets/fish/Makefile.am
@@ -77,13 +77,11 @@ ui_DATA = fish.ui
xmluidir = $(datadir)/mate-panel/ui
xmlui_DATA = fish-menu.xml
-gsettings_SCHEMAS = org.mate.panel.applet.fish.gschema.xml
+fish_gschemas_in = org.mate.panel.applet.fish.gschema.xml.in
+gsettings_SCHEMAS = $(fish_gschemas_in:.xml.in=.xml)
@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
-%.gschema.xml.in: %.gschema.xml.in.in Makefile
- $(AM_V_GEN) $(SED) -e 's^\@GETTEXT_PACKAGE\@^$(GETTEXT_PACKAGE)^g' < $< > $@
-
EXTRA_DIST = \
wanda.svg \
$(fishbitmaps_DATA) \
@@ -91,7 +89,7 @@ EXTRA_DIST = \
$(service_in_files) \
$(ui_DATA) \
$(xmlui_DATA) \
- $(gsettings_SCHEMAS).in.in
+ $(fish_gschemas_in)
CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS)