summaryrefslogtreecommitdiff
path: root/applets/notification_area/Makefile.am
diff options
context:
space:
mode:
authorFabien Broquard <[email protected]>2018-10-02 20:29:38 +0200
committerlukefromdc <[email protected]>2018-10-20 13:35:24 -0400
commit10b9c30fc79de5f8d9516ba153df233c4968da65 (patch)
treeb88e4afea6a47a1f98e89c72e5928cee5ecffcf1 /applets/notification_area/Makefile.am
parentc7d431d36f8bf6e9b94bab37c19dd51041e117c9 (diff)
downloadmate-panel-10b9c30fc79de5f8d9516ba153df233c4968da65.tar.bz2
mate-panel-10b9c30fc79de5f8d9516ba153df233c4968da65.tar.xz
na-tray: wide panels, add GSettings to the applet
The new GSettings allow to change and remember the minimum icon size for the grid. The default icon size is set at 24px.
Diffstat (limited to 'applets/notification_area/Makefile.am')
-rw-r--r--applets/notification_area/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/applets/notification_area/Makefile.am b/applets/notification_area/Makefile.am
index b584f084..67d4f8c6 100644
--- a/applets/notification_area/Makefile.am
+++ b/applets/notification_area/Makefile.am
@@ -93,6 +93,9 @@ org.mate.panel.applet.NotificationAreaAppletFactory.service: $(service_in_files)
$< > $@
endif
+notification_area_gschemas_in = org.mate.panel.applet.notification-area.gschema.xml.in
+gsettings_SCHEMAS = $(notification_area_gschemas_in:.xml.in=.xml)
+
ui_FILES = \
notification-area-menu.xml
@@ -106,8 +109,12 @@ BUILT_SOURCES = \
na-resources.c \
na-resources.h
+@INTLTOOL_XML_NOMERGE_RULE@
+@GSETTINGS_RULES@
+
EXTRA_DIST = \
org.mate.panel.NotificationAreaApplet.mate-panel-applet.in.in \
+ $(notification_area_gschemas_in) \
$(ui_FILES) \
na.gresource.xml \
$(service_in_files)
@@ -115,6 +122,7 @@ EXTRA_DIST = \
CLEANFILES = \
$(applet_DATA) \
$(applet_DATA).in \
- $(service_DATA)
+ $(service_DATA) \
+ $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk