summaryrefslogtreecommitdiff
path: root/applets/wncklet/Makefile.am
diff options
context:
space:
mode:
authorVincent Untz <[email protected]>2012-02-02 12:22:04 +0100
committerraveit65 <[email protected]>2018-04-26 13:01:37 +0200
commite1db0723dfba93d36d36b3b4e4327e9965aa90d4 (patch)
tree8e2cdb4ea34596edc29d58142561a1216313e0e8 /applets/wncklet/Makefile.am
parent1b7c43adfa25eee678661e4d56dfa37888ff27c0 (diff)
downloadmate-panel-e1db0723dfba93d36d36b3b4e4327e9965aa90d4.tar.bz2
mate-panel-e1db0723dfba93d36d36b3b4e4327e9965aa90d4.tar.xz
wncklet: Convert to GResource
origin commits: https://git.gnome.org/browse/gnome-panel/commit/?h=gnome-3-4&id=9fbca7d https://git.gnome.org/browse/gnome-panel/commit/?h=gnome-3-4&id=695d30c https://git.gnome.org/browse/gnome-panel/commit/?h=gnome-3-4&id=00f9870
Diffstat (limited to 'applets/wncklet/Makefile.am')
-rw-r--r--applets/wncklet/Makefile.am34
1 files changed, 20 insertions, 14 deletions
diff --git a/applets/wncklet/Makefile.am b/applets/wncklet/Makefile.am
index db61f873..84682ee9 100644
--- a/applets/wncklet/Makefile.am
+++ b/applets/wncklet/Makefile.am
@@ -6,9 +6,6 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/libmate-panel-applet \
-I$(top_builddir)/libmate-panel-applet \
-DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
- -DPAGER_BUILDERDIR=\""$(uidir)"\" \
- -DTASKLIST_BUILDERDIR=\""$(uidir)"\" \
- -DWNCK_MENU_UI_DIR=\""$(xmluidir)"\" \
$(DISABLE_DEPRECATED_CFLAGS)
AM_CFLAGS = $(WARN_CFLAGS)
@@ -23,7 +20,8 @@ WNCKLET_SOURCES = \
workspace-switcher.c \
workspace-switcher.h \
showdesktop.c \
- showdesktop.h
+ showdesktop.h \
+ $(BUILT_SOURCES)
WNCKLET_LDADD = \
../../libmate-panel-applet/libmate-panel-applet-4.la \
@@ -74,15 +72,23 @@ org.mate.panel.applet.WnckletFactory.service: $(service_in_files)
$< > $@
endif
-uidir = $(datadir)/mate-panel/ui
-ui_DATA = workspace-switcher.ui window-list.ui
-
-xmluidir = $(datadir)/mate-panel/ui
-xmlui_DATA = \
+ui_FILES = \
+ showdesktop-menu.xml \
+ window-list-menu.xml \
+ window-list.ui \
window-menu-menu.xml \
workspace-switcher-menu.xml \
- showdesktop-menu.xml \
- window-list-menu.xml
+ workspace-switcher.ui
+
+wncklet-resources.c: wncklet.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/wncklet.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate --c-name wncklet $<
+
+wncklet-resources.h: wncklet.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/wncklet.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate --c-name wncklet $<
+
+BUILT_SOURCES = \
+ wncklet-resources.c \
+ wncklet-resources.h
wncklet_gschemas_in = \
org.mate.panel.applet.window-list.gschema.xml.in \
@@ -95,10 +101,10 @@ gsettings_SCHEMAS = $(wncklet_gschemas_in:.xml.in=.xml)
EXTRA_DIST = \
org.mate.panel.Wncklet.mate-panel-applet.in.in \
$(service_in_files) \
- $(xmlui_DATA) \
$(wncklet_gschemas_in) \
- $(ui_DATA)
+ $(ui_FILES) \
+ wncklet.gresource.xml
-CLEANFILES = $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS)
+CLEANFILES = $(BUILT_SOURCES) $(applet_DATA) $(applet_DATA).in $(service_DATA) $(gsettings_SCHEMAS)
-include $(top_srcdir)/git.mk