summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Wold <[email protected]>2020-10-02 14:59:32 -0700
committerraveit65 <[email protected]>2020-10-21 20:35:15 +0200
commit217aa88c0f53775abe472f10a16cd48769d7befe (patch)
tree3d27415d3cdc569018b8f70651c1123a376ae45d /configure.ac
parent9d924d645af59fd73110c710f186670869a7e569 (diff)
downloadmate-panel-217aa88c0f53775abe472f10a16cd48769d7befe.tar.bz2
mate-panel-217aa88c0f53775abe472f10a16cd48769d7befe.tar.xz
Link with libwayland
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3d3ec256..4772dff6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,7 @@ AC_ARG_ENABLE(wayland,
# Check if we have gtk-layer-shell installed, and thus should build with Wayland support
have_wayland=no
if test "x$enable_wayland" != "xno"; then
- PKG_CHECK_MODULES(GTK_LAYER_SHELL, gtk-layer-shell-0, have_wayland=yes, [
+ PKG_CHECK_MODULES(WAYLAND, gtk-layer-shell-0 wayland-client, have_wayland=yes, [
if test "x$enable_wayland" = "xyes"; then
AC_MSG_ERROR([Wayland enabled but GTK Layer Shell library not found])
fi
@@ -207,8 +207,8 @@ if test "x$have_wayland" = "xyes"; then
AC_DEFINE(HAVE_WAYLAND, 1, [Have the Wayland development library])
fi
-AC_SUBST(GTK_LAYER_SHELL_CFLAGS)
-AC_SUBST(GTK_LAYER_SHELL_LIBS)
+AC_SUBST(WAYLAND_CFLAGS)
+AC_SUBST(WAYLAND_LIBS)
# Check if we have the X development libraries
have_x11=no