summaryrefslogtreecommitdiff
path: root/mate-panel/Makefile.am
diff options
context:
space:
mode:
authorWilliam Wold <[email protected]>2019-06-17 20:10:43 +0000
committerraveit65 <[email protected]>2019-06-19 12:51:52 +0200
commitc45e92082b67c5b57a6a4a44551572882a4e6091 (patch)
treed4b245816d0569723c694d0f7ef1c7f06d572341 /mate-panel/Makefile.am
parent517435ea0a864438509102901dbd7e177002e3f3 (diff)
downloadmate-panel-c45e92082b67c5b57a6a4a44551572882a4e6091.tar.bz2
mate-panel-c45e92082b67c5b57a6a4a44551572882a4e6091.tar.xz
Switch out wayland protocols for gtk-layer-shell dependency
Diffstat (limited to 'mate-panel/Makefile.am')
-rw-r--r--mate-panel/Makefile.am19
1 files changed, 4 insertions, 15 deletions
diff --git a/mate-panel/Makefile.am b/mate-panel/Makefile.am
index 76431097..a92190d2 100644
--- a/mate-panel/Makefile.am
+++ b/mate-panel/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = wayland-protocols libegg libmate-panel-applet-private libpanel-util
+SUBDIRS = libegg libmate-panel-applet-private libpanel-util
bin_PROGRAMS = \
mate-panel \
@@ -15,11 +15,7 @@ AM_CPPFLAGS = \
-DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
-DPANELDATADIR=\""$(datadir)/mate-panel"\" \
$(DISABLE_DEPRECATED_CFLAGS)
-
-if ENABLE_WAYLAND
-AM_CPPFLAGS += \
- -I$(top_builddir)/mate-panel/wayland-protocols
-endif
+ $(GTK_LAYER_SHELL_CFLAGS)
AM_CFLAGS = $(WARN_CFLAGS)
@@ -67,9 +63,6 @@ panel_sources = \
panel-reset.c
if ENABLE_WAYLAND
-panel_sources += \
- wayland-protocols/wlr-layer-shell-unstable-v1.c \
- wayland-protocols/xdg-shell.c
endif
if ENABLE_X11
@@ -129,9 +122,6 @@ panel_headers = \
panel-schemas.h
if ENABLE_WAYLAND
-panel_headers += \
- wayland-protocols/wlr-layer-shell-unstable-v1-client.h \
- wayland-protocols/xdg-shell-client.h
endif
if ENABLE_X11
@@ -166,6 +156,7 @@ mate_panel_LDADD = \
$(DCONF_LIBS) \
$(XRANDR_LIBS) \
$(X_LIBS) \
+ $(GTK_LAYER_SHELL_LIBS) \
-lm
if ENABLE_WAYLAND
@@ -305,9 +296,7 @@ EXTRA_DIST = \
panel-test-applets.gresource.xml \
panel-marshal.list \
$(entries_DATA) \
- $(desktop_in_files) \
- wayland-protocols/wlr-layer-shell-unstable-v1.xml \
- wayland-protocols/xdg-shell.xml
+ $(desktop_in_files)
CLEANFILES = \
$(BUILT_SOURCES) \