summaryrefslogtreecommitdiff
path: root/mate-panel/Makefile.am
diff options
context:
space:
mode:
authorWilliam Wold <[email protected]>2019-01-16 05:46:04 -0500
committerraveit65 <[email protected]>2019-03-31 09:51:15 +0200
commitc93ac7768aa3de3498ef7c7bd0766f5d3b6e221d (patch)
tree92fd498f727be7bfde415a038f2fc4060d76bf63 /mate-panel/Makefile.am
parenta5642b9670cff46f03310e4b6d225a5517db9d14 (diff)
downloadmate-panel-c93ac7768aa3de3498ef7c7bd0766f5d3b6e221d.tar.bz2
mate-panel-c93ac7768aa3de3498ef7c7bd0766f5d3b6e221d.tar.xz
Dropped *-protocol suffix from generated files
Diffstat (limited to 'mate-panel/Makefile.am')
-rw-r--r--mate-panel/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/mate-panel/Makefile.am b/mate-panel/Makefile.am
index a7559129..76431097 100644
--- a/mate-panel/Makefile.am
+++ b/mate-panel/Makefile.am
@@ -16,6 +16,11 @@ AM_CPPFLAGS = \
-DPANELDATADIR=\""$(datadir)/mate-panel"\" \
$(DISABLE_DEPRECATED_CFLAGS)
+if ENABLE_WAYLAND
+AM_CPPFLAGS += \
+ -I$(top_builddir)/mate-panel/wayland-protocols
+endif
+
AM_CFLAGS = $(WARN_CFLAGS)
panel_sources = \
@@ -63,8 +68,8 @@ panel_sources = \
if ENABLE_WAYLAND
panel_sources += \
- wayland-protocols/wlr-layer-shell-unstable-v1-protocol.c \
- wayland-protocols/xdg-shell-protocol.c
+ wayland-protocols/wlr-layer-shell-unstable-v1.c \
+ wayland-protocols/xdg-shell.c
endif
if ENABLE_X11
@@ -125,8 +130,8 @@ panel_headers = \
if ENABLE_WAYLAND
panel_headers += \
- wayland-protocols/wlr-layer-shell-unstable-v1-client-protocol.h \
- wayland-protocols/xdg-shell-client-protocol.h
+ wayland-protocols/wlr-layer-shell-unstable-v1-client.h \
+ wayland-protocols/xdg-shell-client.h
endif
if ENABLE_X11