summaryrefslogtreecommitdiff
path: root/libmate-panel-applet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libmate-panel-applet/Makefile.am')
-rw-r--r--libmate-panel-applet/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/libmate-panel-applet/Makefile.am b/libmate-panel-applet/Makefile.am
index b5f6e6c9..e7a2c22a 100644
--- a/libmate-panel-applet/Makefile.am
+++ b/libmate-panel-applet/Makefile.am
@@ -92,13 +92,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libmatepanelapplet-4.0.pc
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.panel.TestApplet.mate-panel-applet.in
-noinst_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
-
-@PANEL_INTLTOOL_MATE_PANEL_APPLET_RULE@
+applet_in_files = org.mate.panel.TestApplet.mate-panel-applet.desktop.in
+noinst_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
+$(noinst_DATA): $(applet_in_files)
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword Name --keyword Description --template $< -d $(top_srcdir)/po -o $@
EXTRA_DIST = \
- org.mate.panel.TestApplet.mate-panel-applet.in \
+ org.mate.panel.TestApplet.mate-panel-applet.desktop.in \
mate-panel-applet-marshal.list \
libmatepanelapplet-4.0.pc.in \
libmatepanelapplet-4.0-uninstalled.pc.in