summaryrefslogtreecommitdiff
path: root/mate-panel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/Makefile.am')
-rw-r--r--mate-panel/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/mate-panel/Makefile.am b/mate-panel/Makefile.am
index 9dd98897..f2f04d27 100644
--- a/mate-panel/Makefile.am
+++ b/mate-panel/Makefile.am
@@ -170,6 +170,8 @@ mate_panel_LDFLAGS = -export-dynamic
mate_desktop_item_edit_SOURCES = \
mate-desktop-item-edit.c \
panel-ditem-editor.c \
+ panel-resources.c \
+ panel-resources.h \
panel-marshal.c \
panel-util.c
@@ -188,6 +190,8 @@ mate_desktop_item_edit_LDADD += \
-lX11
endif
+mate_desktop_item_edit_LDFLAGS = -export-dynamic
+
mate_panel_test_applets_SOURCES = \
$(panel_test_applets_BUILT_SOURCES) \
panel-modules.c \
@@ -266,8 +270,9 @@ BUILT_SOURCES = \
$(mate_panel_BUILT_SOURCES) \
$(panel_test_applets_BUILT_SOURCES)
-ui_FILES = \
- panel-properties-dialog.ui \
+ui_FILES = \
+ panel-ditem-editor-dialog.ui \
+ panel-properties-dialog.ui \
panel-run-dialog.ui
panel-resources.c: panel.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/panel.gresource.xml)