summaryrefslogtreecommitdiff
path: root/mate-panel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/Makefile.am')
-rw-r--r--mate-panel/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/mate-panel/Makefile.am b/mate-panel/Makefile.am
index 2738a67b..f2f04d27 100644
--- a/mate-panel/Makefile.am
+++ b/mate-panel/Makefile.am
@@ -16,7 +16,7 @@ AM_CPPFLAGS = \
-DMATELOCALEDIR=\""$(datadir)/locale"\" \
-DPANELDATADIR=\""$(datadir)/mate-panel"\" \
$(DISABLE_DEPRECATED_CFLAGS) \
- $(GTK_LAYER_SHELL_CFLAGS)
+ $(WAYLAND_CFLAGS)
AM_CFLAGS = $(WARN_CFLAGS)
@@ -72,7 +72,6 @@ panel_sources += \
panel-xutils.c \
panel-force-quit.c \
panel-action-protocol.c \
- panel-background-monitor.c \
panel-struts.c
endif
@@ -133,7 +132,6 @@ panel_sources += \
panel-xutils.h \
panel-force-quit.h \
panel-action-protocol.h \
- panel-background-monitor.h \
panel-struts.h
endif
@@ -152,7 +150,6 @@ mate_panel_CPPFLAGS += \
$(WAYLAND_CFLAGS)
endif
-
mate_panel_LDADD = \
$(top_builddir)/mate-panel/mate-submodules/libegg/libegg.la \
$(top_builddir)/mate-panel/libmate-panel-applet-private/libmate-panel-applet-private.la \
@@ -161,8 +158,7 @@ mate_panel_LDADD = \
$(DCONF_LIBS) \
$(XRANDR_LIBS) \
$(X_LIBS) \
- $(GTK_LAYER_SHELL_LIBS) \
- -lm
+ $(WAYLAND_LIBS)
if ENABLE_WAYLAND
mate_panel_LDADD += \
@@ -174,6 +170,8 @@ mate_panel_LDFLAGS = -export-dynamic
mate_desktop_item_edit_SOURCES = \
mate-desktop-item-edit.c \
panel-ditem-editor.c \
+ panel-resources.c \
+ panel-resources.h \
panel-marshal.c \
panel-util.c
@@ -192,6 +190,8 @@ mate_desktop_item_edit_LDADD += \
-lX11
endif
+mate_desktop_item_edit_LDFLAGS = -export-dynamic
+
mate_panel_test_applets_SOURCES = \
$(panel_test_applets_BUILT_SOURCES) \
panel-modules.c \
@@ -270,8 +270,9 @@ BUILT_SOURCES = \
$(mate_panel_BUILT_SOURCES) \
$(panel_test_applets_BUILT_SOURCES)
-ui_FILES = \
- panel-properties-dialog.ui \
+ui_FILES = \
+ panel-ditem-editor-dialog.ui \
+ panel-properties-dialog.ui \
panel-run-dialog.ui
panel-resources.c: panel.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/panel.gresource.xml)