summaryrefslogtreecommitdiff
path: root/mate-panel/libmate-panel-applet-private/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-panel/libmate-panel-applet-private/Makefile.am')
-rw-r--r--mate-panel/libmate-panel-applet-private/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/mate-panel/libmate-panel-applet-private/Makefile.am b/mate-panel/libmate-panel-applet-private/Makefile.am
new file mode 100644
index 00000000..9dd4b631
--- /dev/null
+++ b/mate-panel/libmate-panel-applet-private/Makefile.am
@@ -0,0 +1,34 @@
+noinst_LTLIBRARIES = \
+ libmate-panel-applet-private.la \
+ libmate-panel-applet-private-mini.la
+
+AM_CPPFLAGS = \
+ $(PANEL_CFLAGS) \
+ -I. \
+ -I$(srcdir) \
+ -I$(top_srcdir)/mate-panel \
+ -I$(top_builddir)/mate-panel \
+ -I$(top_builddir)/mate-panel/libmate-panel-applets-private \
+ -I$(top_builddir)/mate-panel/libpanel-util \
+ -DDATADIR=\""$(datadir)"\" \
+ -DMATE_PANEL_APPLETS_DIR=\"$(appletsdir)\" \
+ $(DISABLE_DEPRECATED_CFLAGS)
+
+AM_CFLAGS = $(WARN_CFLAGS)
+
+libmate_panel_applet_private_la_SOURCES = \
+ mate-panel-applets-manager-dbus.c \
+ mate-panel-applets-manager-dbus.h \
+ mate-panel-applet-container.c \
+ mate-panel-applet-container.h \
+ mate-panel-applet-frame-dbus.c \
+ mate-panel-applet-frame-dbus.h
+
+libmate_panel_applet_private_mini_la_SOURCES =\
+ mate-panel-applet-mini.c \
+ mate-panel-applets-manager-dbus.c \
+ mate-panel-applets-manager-dbus.h \
+ mate-panel-applet-container.c \
+ mate-panel-applet-container.h
+
+-include $(top_srcdir)/git.mk