summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-12 12:03:15 +0200
committerinfirit <[email protected]>2015-09-12 12:03:15 +0200
commitb06d4ae63fc95f50870510ca0acbaf049ba6dbb2 (patch)
treeddb78b27eba1719843015ee5adafc57a9a008315 /src/Makefile.am
parent0160a96e5630d84b92e3e87fc072d3558b03baab (diff)
downloadmate-polkit-b06d4ae63fc95f50870510ca0acbaf049ba6dbb2.tar.bz2
mate-polkit-b06d4ae63fc95f50870510ca0acbaf049ba6dbb2.tar.xz
Return error when authentication dialog is dismissed
This allows PolicyKit applications to disambiguate between when the authentication dialog is dismissed versus when authentication fails (e.g. the wrong password has been entered). From polkit-gnome, commit: 2511afae6b72fe3b4714d07ab6373c93c2923a5e From: David Zeuthen <[email protected]> Gnome bug: https://bugs.freedesktop.org/show_bug.cgi?id=30653
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d1d8136..eb2fcfc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,6 +30,7 @@ polkit_mate_authentication_agent_1_CPPFLAGS = \
polkit_mate_authentication_agent_1_CFLAGS = \
$(GTK_CFLAGS) \
+ $(GLIB_CFLAGS) \
$(POLKIT_AGENT_CFLAGS) \
$(POLKIT_GOBJECT_CFLAGS) \
$(WARN_CFLAGS) \
@@ -40,6 +41,7 @@ polkit_mate_authentication_agent_1_LDFLAGS = \
polkit_mate_authentication_agent_1_LDADD = \
$(GTK_LIBS) \
+ $(GLIB_LIBS) \
$(POLKIT_AGENT_LIBS) \
$(POLKIT_GOBJECT_LIBS) \
$(INTLLIBS)