summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-12-16 20:33:52 +0100
committerinfirit <[email protected]>2013-12-16 20:33:52 +0100
commit94ed1e0d61792d877f87f96fafefcd7a860dc56f (patch)
tree3aaf0f7bb914d8b8db66d8b21ff2a89d99f8c52e /Makefile.am
parent751286f696bb611e65d69f0db41a8b6523e273e6 (diff)
downloadmate-power-manager-94ed1e0d61792d877f87f96fafefcd7a860dc56f.tar.bz2
mate-power-manager-94ed1e0d61792d877f87f96fafefcd7a860dc56f.tar.xz
Update changelog generation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 11 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index bc08da9..f331bf2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,23 +40,16 @@ DISTCHECK_CONFIGURE_FLAGS = \
--disable-applets \
--disable-tests
-distclean-local:
- if test $(srdcir) = .; then :; else \
- rm -f ChangeLog; \
- fi
-
-ChangeLog:
- @echo Creating $@
- @if test -d "$(srcdir)/.git"; then \
- (GIT_DIR=$(top_srcdir)/.git ./missing --run git log --stat -M -C --name-status --date=short --no-color) | fmt --split-only > [email protected] \
- && mv -f [email protected] $@ \
- || ($(RM) [email protected]; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
- (test -f $@ || echo git-log is required to generate this file >> $@)); \
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
else \
- test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
+ echo A git clone is required to generate a ChangeLog >&2; \
fi
-
-.PHONY: ChangeLog