summaryrefslogtreecommitdiff
path: root/applets/inhibit/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-11 12:55:19 +0100
committerStefano Karapetsas <[email protected]>2011-12-11 12:55:19 +0100
commit51175189c6d7313a3b84019e39496f957c4e6164 (patch)
treee4c2c130fa3140bca28685ef900f04a012e53dcd /applets/inhibit/Makefile.am
downloadmate-power-manager-51175189c6d7313a3b84019e39496f957c4e6164.tar.bz2
mate-power-manager-51175189c6d7313a3b84019e39496f957c4e6164.tar.xz
moved from Mate-Extra
Diffstat (limited to 'applets/inhibit/Makefile.am')
-rw-r--r--applets/inhibit/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/applets/inhibit/Makefile.am b/applets/inhibit/Makefile.am
new file mode 100644
index 0000000..fb42774
--- /dev/null
+++ b/applets/inhibit/Makefile.am
@@ -0,0 +1,55 @@
+INCLUDES = \
+ -I. -I$(srcdir) \
+ $(GLIB_CFLAGS) \
+ $(DBUS_CFLAGS) \
+ $(MATE_CFLAGS) \
+ $(PANEL_CFLAGS) \
+ $(LIBMATENOTIFY_CFLAGS) \
+ $(GTKUNIQUE_CFLAGS) \
+ -DBINDIR=\"$(bindir)\" \
+ -DMATELOCALEDIR=\""$(datadir)/locale"\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DVERSION="\"$(VERSION)\"" \
+ -DGPM_DATA=\"$(pkgdatadir)\" \
+ -DEGG_LOG_FILE=\""~/mate-power-manager.log"\" \
+ -DEGG_VERBOSE="\"GPM_VERBOSE\"" \
+ -DEGG_LOGGING="\"GPM_LOGGING\"" \
+ -DEGG_CONSOLE="\"GPM_CONSOLE\"" \
+ -I$(top_srcdir)/libdbus-glib \
+ $(NULL)
+
+libexec_PROGRAMS=mate-inhibit-applet
+
+mate_inhibit_applet_SOURCES = \
+ inhibit-applet.c \
+ egg-dbus-monitor.c \
+ egg-dbus-monitor.h \
+ egg-debug.c \
+ egg-debug.h \
+ gpm-common.c \
+ gpm-common.h
+
+mate_inhibit_applet_LDADD = \
+ $(DBUS_LIBS) \
+ $(MATE_LIBS) \
+ $(PANEL_LIBS)
+
+serverdir = $(libdir)/matecomponent/servers
+server_in_files = MATE_InhibitApplet.server.in
+server_DATA = $(server_in_files:.server.in=.server)
+
+$(server_in_files): $(server_in_files:.server.in=.server.in.in)
+ sed -e "s|\@LIBEXECDIR\@|$(libexecdir)|" -e "s|\@VERSION\@|$(VERSION)|" $< > $@
+
+@INTLTOOL_SERVER_RULE@
+
+uidir = $(datadir)/mate-2.0/ui
+ui_DATA = MATE_InhibitApplet.xml
+
+EXTRA_DIST = MATE_InhibitApplet.server.in.in $(ui_DATA)
+
+DISTCLEANFILES = \
+ $(server_DATA) $(server_DATA).in