summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-12-16 20:55:26 +0100
committerinfirit <[email protected]>2013-12-16 21:00:33 +0100
commit1c0b5b5e50041987d46f974cc75f1981e7ec977e (patch)
tree7ea41de2b684b80ac8036e366c8d98b1004e9b10 /configure.ac
parent94ed1e0d61792d877f87f96fafefcd7a860dc56f (diff)
downloadmate-power-manager-1c0b5b5e50041987d46f974cc75f1981e7ec977e.tar.bz2
mate-power-manager-1c0b5b5e50041987d46f974cc75f1981e7ec977e.tar.xz
Add option to enable deprecations and hide warnings under --enable-extra-warn
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0976d85..c5bd72f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,7 +44,31 @@ if test x$enable_strict != xno; then
fi
fi
-if test "$GCC" = "yes"; then
+AC_ARG_ENABLE(deprecated,
+ [AS_HELP_STRING([--enable-deprecated],
+ [Warn about deprecated usages [default=no]])],,
+ [enable_deprecated=no])
+
+if test "x$enable_deprecated" = "xno"; then
+ DISABLE_DEPRECATED=" \
+ -DG_DISABLE_SINGLE_INCLUDES \
+ -DGTK_DISABLE_SINGLE_INCLUDES \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGDK_MULTIHEAD_SAFE \
+ -DGTK_MULTIHEAD_SAFE \
+ -DGSEAL_ENABLE"
+
+ CPPFLAGS="$CPPFLAGS $DISABLE_DEPRECATED"
+fi
+
+AC_ARG_ENABLE(extra-warn,
+ [AS_HELP_STRING([--enable-extra-warn],
+ [Enable extra warnings. gcc only. [default=no]])],,
+ [enable_extra_warn=no])
+
+if test "x$enable_extra_warn" = "xyes" && test "$GCC" = "yes"; then
WARNINGFLAGS="$WARNINGFLAGS -Wall"
WARNINGFLAGS="$WARNINGFLAGS -Wcast-align -Wno-uninitialized"
WARNINGFLAGS="$WARNINGFLAGS -Wmissing-declarations"