summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2012-11-22 08:41:47 -0800
committerStefano Karapetsas <[email protected]>2012-11-22 08:41:47 -0800
commit433b548ea199a66afbb5fc874bfdaa31695c1e3c (patch)
tree061e2ccdef2078e433d53ef3e1fb14f51766f830 /configure.ac
parent237f70ff586bffba55aaefb2af1128d7f321cb30 (diff)
parent30eed18125a03a0bede7f5e560f8f031db70dcbe (diff)
downloadmate-power-manager-433b548ea199a66afbb5fc874bfdaa31695c1e3c.tar.bz2
mate-power-manager-433b548ea199a66afbb5fc874bfdaa31695c1e3c.tar.xz
Merge pull request #37 from Firstyear/systemd-inhibit
Systemd inhibit support for MPM
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 312f220..6e36106 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,6 +270,25 @@ AC_MSG_RESULT([$have_applets])
AM_CONDITIONAL([HAVE_APPLETS], [test $have_applets = yes])
dnl ---------------------------------------------------------------------------
+dnl systemd inhibit
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH(systemdinhibit,
+ AS_HELP_STRING([--with-systemdinhibit],
+ [Add systemdinhibit support]),,
+ with_systemdinhibit=auto)
+
+use_systemdinhibit=no
+if test "x$with_systemdinhibit" != "xno" ; then
+ use_systemdinhibit=yes
+ AC_DEFINE(WITH_SYSTEMD_INHIBIT, 1, [systemdinhibit support])
+
+ PKG_CHECK_MODULES(SYSTEMD_INHIBIT, libsystemd-login libsystemd-daemon)
+fi
+AM_CONDITIONAL(WITH_SYSTEMD_INHIBIT, test x$use_systemdinhibit = xyes)
+AC_SUBST(WITH_SYSTEMD_INHIBIT)
+
+dnl ---------------------------------------------------------------------------
dnl - DocBook Documentation
dnl ---------------------------------------------------------------------------
AC_ARG_ENABLE(docbook-docs,
@@ -382,6 +401,7 @@ echo "
Building extra applets: ${enable_applets}
Self test support: ${have_tests}
Use libunique: ${enable_libunique}
+ systemd support: ${use_systemdinhibit}
Docbook support: ${enable_docbook_docs}
documentation dir: $DOCDIR
dbus-1 services dir: $DBUS_SERVICES_DIR