summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-08 13:50:20 +0200
committerinfirit <[email protected]>2015-09-08 13:50:20 +0200
commitf4b68b94578486aae471e522c64919fd2cf004bc (patch)
treef3e7d7a6920d6ad11c3a4be776bc89818e2f7430 /data/Makefile.am
parent8775ad4d201ce725594b96091ab300de0c5cb544 (diff)
downloadmate-power-manager-f4b68b94578486aae471e522c64919fd2cf004bc.tar.bz2
mate-power-manager-f4b68b94578486aae471e522c64919fd2cf004bc.tar.xz
Rework gsettings schema building
* Bump intltool required version for gsettings support * Extract strings with intltool directly * Let autoconf generate the xml files * Add gettext domain to gschema
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 398fd0c..e5544dc 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -22,7 +22,7 @@ $(service_DATA): $(service_in_files) Makefile
@GSETTINGS_RULES@
@INTLTOOL_XML_NOMERGE_RULE@
gsettings_schemas_in_files = org.mate.power-manager.gschema.xml.in
-gsettings_SCHEMAS = $(gsettings_schemas_in_files:.gschema.xml.in=.gschema.xml)
+gsettings_SCHEMAS = $(gsettings_schemas_in_files:.xml.in=.xml)
convertdir = $(datadir)/MateConf/gsettings
convert_DATA = mate-power-manager.convert
@@ -34,7 +34,6 @@ pkgdata_DATA = \
acme.ui
EXTRA_DIST = \
- $(gsettings_SCHEMAS) \
$(service_in_files) \
$(autostart_in_files) \
$(desktop_in_files) \
@@ -49,5 +48,5 @@ DISTCLEANFILES = \
mate-power-manager.desktop \
mate-power-preferences.desktop \
mate-power-statistics.desktop \
- org.mate.PowerManager.service \
- org.mate.power-manager.gschema.xml
+ org.mate.PowerManager.service \
+ $(gsettings_SCHEMAS)