summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-05-02 12:29:00 +0200
committerStefano Karapetsas <[email protected]>2013-05-02 12:29:00 +0200
commit154d6784a0927d9e0e8f81fe0d1179a16690689e (patch)
treeaf6d101f9e3c6c5bf1e01ef5a3f2d325574e6212 /src/Makefile.am
parentacbec2f8c4c0bf0227bd9e43c3c74cea0974ebc3 (diff)
downloadmate-power-manager-154d6784a0927d9e0e8f81fe0d1179a16690689e.tar.bz2
mate-power-manager-154d6784a0927d9e0e8f81fe0d1179a16690689e.tar.xz
Fixes for make dist and make distcheck
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a49e87a..5fda8ee 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -49,8 +49,10 @@ sbin_PROGRAMS = \
mate-power-backlight-helper \
$(NULL)
+if HAVE_TESTS
check_PROGRAMS = \
mate-power-self-test
+endif
noinst_LIBRARIES = libgpmshared.a
libgpmshared_a_SOURCES = \
@@ -199,6 +201,7 @@ mate_power_manager_CFLAGS = \
$(WARNINGFLAGS) \
$(NULL)
+if HAVE_TESTS
mate_power_self_test_SOURCES = \
gpm-self-test.c \
egg-color.h \
@@ -263,6 +266,7 @@ mate_power_self_test_LDADD = \
-lm
mate_power_self_test_CFLAGS = -DEGG_TEST $(AM_CFLAGS) $(WARNINGFLAGS)
+endif
BUILT_SOURCES = \
org.mate.PowerManager.h \
@@ -298,7 +302,9 @@ clean-local:
CLEANFILES = $(BUILT_SOURCES)
+if HAVE_TESTS
TESTS = mate-power-self-test
+endif
MAINTAINERCLEANFILES = \
*~ \