summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ad322c6..eb12978 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,20 @@ YELP_HELP_INIT
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+# GLIB_COMPILE_RESOURCES
+AC_ARG_VAR([GLIB_COMPILE_RESOURCES],[glib-compile-resources bin])
+AC_PATH_PROG([GLIB_COMPILE_RESOURCES],[glib-compile-resources],[])
+if test -z "$GLIB_COMPILE_RESOURCES"; then
+ AC_MSG_ERROR([glib-compile-resources not found])
+fi
+
+# XMLLINT
+AC_ARG_VAR([XMLLINT],[xmllint bin])
+AC_PATH_PROG([XMLLINT],[xmllint],[])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint not found])
+fi
+
AC_ARG_ENABLE(deprecated,
[AS_HELP_STRING([--enable-deprecated],
[Warn about deprecated usages [default=no]])],,