summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..aa1f8ec
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,27 @@
+EXTRA_DIST = \
+ mate-power-manager.sgml \
+ mate-power-statistics.sgml \
+ mate-power-preferences.sgml
+
+if HAVE_DOCBOOK2MAN
+man_MANS = \
+ mate-power-manager.1 \
+ mate-power-statistics.1 \
+ mate-power-preferences.1
+endif
+
+if HAVE_DOCBOOK2MAN
+mate-power-manager.1: mate-power-manager.sgml
+ docbook2man $? &> /dev/null
+
+mate-power-preferences.1: mate-power-preferences.sgml
+ docbook2man $? &> /dev/null
+
+mate-power-statistics.1: mate-power-statistics.sgml
+ docbook2man $? &> /dev/null
+endif
+
+clean-local :
+ rm -f *~
+ rm -f *.1
+ rm -f manpage.*