summaryrefslogtreecommitdiff
path: root/savers/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-10-15 14:11:46 +0800
committerVictor Kareh <[email protected]>2019-10-29 09:18:58 -0400
commitbce4817d3c2ddc150582db8451f3d92a5a2df5da (patch)
tree32e184c11e7b49ba3aaff5b3c851cb1837bb7bb8 /savers/Makefile.am
parent64b09837c0e3eea6e4f546fc3d2718e4c52bfdde (diff)
downloadmate-screensaver-bce4817d3c2ddc150582db8451f3d92a5a2df5da.tar.bz2
mate-screensaver-bce4817d3c2ddc150582db8451f3d92a5a2df5da.tar.xz
migrate from intltool to gettext
Diffstat (limited to 'savers/Makefile.am')
-rw-r--r--savers/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/savers/Makefile.am b/savers/Makefile.am
index 4f590cf..267a44a 100644
--- a/savers/Makefile.am
+++ b/savers/Makefile.am
@@ -23,17 +23,15 @@ DESKTOP_IN_IN_FILES = \
$(NULL)
cosmos-slideshow.desktop.in: cosmos-slideshow.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
footlogo-floaters.desktop.in: footlogo-floaters.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
gnomelogo-floaters.desktop.in: gnomelogo-floaters.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
personal-slideshow.desktop.in: personal-slideshow.desktop.in.in Makefile
- $(edit) $< >$@
+ @$(edit) $< >$@
popsquares.desktop.in: popsquares.desktop.in.in Makefile
- $(edit) $< >$@
-
-@INTLTOOL_DESKTOP_RULE@
+ @$(edit) $< >$@
edit = sed \
-e 's|@SLIDESHOW_COSMOS_DIR[@]|$(SLIDESHOW_COSMOS_DIR)|g' \
@@ -41,6 +39,9 @@ edit = sed \
-e 's|@FLOATERS_FOOT_GNOME_LOGO_IMAGE[@]|$(FLOATERS_FOOT_GNOME_LOGO_IMAGE)|g' \
-e 's|@SAVERDIR[@]|$(privlibexecdir)|g'
+%.desktop: %.desktop.in
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
themesdir = $(datadir)/applications/screensavers
themes_in_files = \
cosmos-slideshow.desktop.in \