summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRobert Nagy <[email protected]>2017-03-28 20:31:42 +0200
committermonsta <[email protected]>2017-04-18 21:30:24 +0300
commit5f70d320a0d3d1fef0bc6b7b77ef2a7c2923b990 (patch)
treea72e9ff665cdaf39ea183c08965663a9cf5aa1c7 /src/Makefile.am
parentf2567e0fe617c8cfd88bd6fd9dfe2505f497654f (diff)
downloadmate-screensaver-5f70d320a0d3d1fef0bc6b7b77ef2a7c2923b990.tar.bz2
mate-screensaver-5f70d320a0d3d1fef0bc6b7b77ef2a7c2923b990.tar.xz
Implement OpenBSD authentication using bsd_auth(3).
OpenBSD does not have nor use pam(8) for password authentication but instead uses bsd_auth(3): add a bsd_auth authentication scheme to make locking possible. This has been a part of gnome-screensaver already but was probably removed at one point. This is mostly identical to that code, with some minor modifications.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 298382d..9b32abf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -256,9 +256,13 @@ install-exec-hook:
@if [ "x@NEED_SETUID@" = "xyes" ]; then \
echo "***" ; \
echo "*** Warning: mate-screensaver has been compiled with support for" ; \
- echo "*** shadow passwords. If your system actually uses shadow" ; \
- echo "*** passwords then it must be installed as a setuid root" ; \
- echo "*** program in order for locking to work. To do this, you" ; \
+ if [ "x@AUTH_SCHEME@" = "xbsdauth" ]; then \
+ echo "*** bsd_auth(3) and must be installed as a setuid root" ; \
+ else \
+ echo "*** shadow passwords. If your system actually uses shadow" ; \
+ echo "*** passwords then it must be installed as a setuid root" ; \
+ fi; \
+ echo "*** program in order for locking to work. To do this, you" ; \
echo "*** must run:" ; \
echo "***" ; \
echo "*** chown root $(DESTDIR)$(libexecdir)/mate-screensaver-dialog" ; \