summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2019-12-26 10:28:44 +0800
committerZenWalker <[email protected]>2020-01-05 14:02:20 +0100
commit81dabea49de06f0cca6cdd620bc8b18c7dbf961f (patch)
treecb6227d61a91fe7ce4ab1a05cb59cb1c792364c9 /Makefile.am
parent5e8a0c59e6d2031096db0e592c737774d02f4aeb (diff)
downloadmate-sensors-applet-81dabea49de06f0cca6cdd620bc8b18c7dbf961f.tar.bz2
mate-sensors-applet-81dabea49de06f0cca6cdd620bc8b18c7dbf961f.tar.xz
migrate from intltools to gettext
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 91fe2ee..6b9b329 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,15 +3,16 @@ SUBDIRS = sensors-applet lib plugins pixmaps po help
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
appletdir = $(datadir)/mate-panel/applets
-applet_in_files = org.mate.applets.SensorsApplet.mate-panel-applet.in
-applet_DATA = $(applet_in_files:.mate-panel-applet.in=.mate-panel-applet)
+applet_in_files = org.mate.applets.SensorsApplet.mate-panel-applet.desktop.in
+applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-%.mate-panel-applet: %.mate-panel-applet.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+$(applet_DATA): $(applet_in_files) Makefile
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
uidir = $(datadir)/mate-sensors-applet/ui
ui_DATA = SensorsApplet.xml
@@ -25,7 +26,6 @@ org.mate.panel.applet.SensorsAppletFactory.service: $(service_in_files)
-e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
$< > $@
-@INTLTOOL_XML_NOMERGE_RULE@
gsettingsschema_in_files = \
org.mate.sensors-applet.gschema.xml.in \
org.mate.sensors-applet.sensor.gschema.xml.in
@@ -34,7 +34,7 @@ gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
@GSETTINGS_RULES@
CLEANFILES = $(applet_DATA) \
- $(applet_DATA).in \
+ $(applet_in_files) \
$(service_DATA) \
$(gsettings_SCHEMAS) \
*.gschema.valid
@@ -48,9 +48,7 @@ EXTRA_DIST = $(ui_DATA) \
$(gsettingsschema_in_files) \
autogen.sh
-DISTCLEANFILES = intltool-extract \
- intltool-merge \
- intltool-update
+DISTCLEANFILES =
MSACLEANFILES = aclocal.m4 \
compile \