summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c595113..5ec52b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,21 @@ SUBDIRS = sensors-applet lib plugins pixmaps po help
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-APPLET_LOCATION = $(libdir)/mate-sensors-applet/libmate_sensors_applet.so
+if ENABLE_IN_PROCESS
+APPLET_LOCATION = $(libdir)/mate-sensors-applet/libmate-sensors-applet.so
+else
+APPLET_LOCATION = $(libexecdir)/mate-sensors-applet
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.mate.panel.applet.SensorsAppletFactory.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+org.mate.panel.applet.SensorsAppletFactory.service: $(service_in_files)
+ $(AM_V_GEN)sed \
+ -e "s|\@LIBEXECDIR\@|$(libexecdir)|" \
+ $< > $@
+
+endif
appletdir = $(datadir)/mate-panel/applets
applet_in_files = org.mate.applets.SensorsApplet.mate-panel-applet.desktop.in
@@ -11,6 +25,7 @@ applet_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet
$(applet_in_files): $(applet_in_files).in Makefile
$(AM_V_GEN)sed \
-e "s|\@APPLET_LOCATION\@|$(APPLET_LOCATION)|" \
+ -e "s|\@APPLET_IN_PROCESS\@|$(APPLET_IN_PROCESS)|" \
-e "s|\@VERSION\@|$(PACKAGE_VERSION)|" \
$< > $@
@@ -29,6 +44,7 @@ gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)
CLEANFILES = $(applet_DATA) \
$(applet_in_files) \
+ $(service_DATA) \
$(gsettings_SCHEMAS) \
*.gschema.valid
@@ -38,6 +54,7 @@ DISTCHECK_CONFIGURE_FLAGS = \
EXTRA_DIST = $(ui_DATA) \
$(applet_in_files).in \
+ $(service_in_files) \
$(gsettingsschema_in_files) \
autogen.sh