summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <[email protected]>2022-07-25 15:19:12 +0200
committerraveit65 <[email protected]>2023-04-15 21:12:23 +0200
commitade769d7a5a577d6a7936c75fac1867df9ad719e (patch)
tree01d95cfe1112a0a3397449a95c986ff84d4e221b /configure.ac
parent900de4f4be768a4a199cb856311c7e43ab4e506a (diff)
downloadmate-session-manager-ade769d7a5a577d6a7936c75fac1867df9ad719e.tar.bz2
mate-session-manager-ade769d7a5a577d6a7936c75fac1867df9ad719e.tar.xz
configure.ac: The macro 'AC_HELP_STRING' is obsolete
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0c07c34..635b180 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,7 @@ AC_SUBST(ACLOCAL_AMFLAGS, "\${ACLOCAL_FLAGS}")
MATE_MAINTAINER_MODE_DEFINES
AC_ARG_ENABLE(deprecations,
- [AC_HELP_STRING([--enable-deprecations],
+ [AS_HELP_STRING([--enable-deprecations],
[warn about deprecated usages @<:@default=no@:>@])],,
[enable_deprecations=no])
@@ -73,7 +73,7 @@ dnl ====================================================================
dnl GLESV2 (optional)
dnl ====================================================================
-AC_ARG_WITH([libglesv2], AC_HELP_STRING([--without-libglesv2], [disable GLESV2 support]))
+AC_ARG_WITH([libglesv2], AS_HELP_STRING([--without-libglesv2], [disable GLESV2 support]))
have_glesv2=no
if test x$with_libglesv2 != xno; then
PKG_CHECK_MODULES(GLES_TEST, egl glesv2, have_glesv2=yes, have_glesv2=no)
@@ -87,7 +87,7 @@ dnl ====================================================================
dnl Option to set the default window manager
dnl ====================================================================
AC_ARG_WITH(default-wm,
- [AC_HELP_STRING([--with-default-wm],
+ [AS_HELP_STRING([--with-default-wm],
[Specify the default window manager @<:@default=marco@:>@])],,
[with_default_wm="marco"])
@@ -193,7 +193,7 @@ dnl - DocBook Documentation
dnl ====================================================================
AC_ARG_ENABLE(docbook-docs,
- [AC_HELP_STRING([--enable-docbook-docs],
+ [AS_HELP_STRING([--enable-docbook-docs],
[build documentation (requires xmlto)])],
enable_docbook_docs=$enableval,enable_docbook_docs=auto)
AC_PATH_PROG(XMLTO, xmlto, no)
@@ -268,7 +268,7 @@ dnl Code for checking whether IPv6 is enabled on the system....
dnl ====================================================================
AC_MSG_CHECKING([whether to enable ipv6])
AC_ARG_ENABLE(ipv6,
- AC_HELP_STRING([--enable-ipv6], [enable IPv6 extensions]),,
+ AS_HELP_STRING([--enable-ipv6], [enable IPv6 extensions]),,
[enable_ipv6=yes])
have_full_ipv6=no
if test $enable_ipv6 = yes; then
@@ -315,7 +315,7 @@ AC_PATH_PROGS(PERL, perl5 perl)
# define a MAINT-like variable REBUILD which is set if Perl
# and awk are found, so autogenerated sources can be rebuilt
AC_ARG_ENABLE(rebuilds,
- AC_HELP_STRING([--disable-rebuilds],
+ AS_HELP_STRING([--disable-rebuilds],
[disable all source autogeneration rules]),,
[enable_rebuilds=yes])
REBUILD=\#