summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorrbuj <[email protected]>2021-02-18 10:59:50 +0100
committerraveit65 <[email protected]>2021-02-24 16:05:39 +0100
commitd105267f775b4371a670f016c9fbce7e81b2632a (patch)
treed3085f4d43d7fdcb41d80636404ac15720388ce3 /data/Makefile.am
parent036594c5542272f719994a62a4663fce998e26f2 (diff)
downloadmate-session-manager-d105267f775b4371a670f016c9fbce7e81b2632a.tar.bz2
mate-session-manager-d105267f775b4371a670f016c9fbce7e81b2632a.tar.xz
build: allow users to disable gettext support (--disable-nls)
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index fbee59d..c74a669 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -23,7 +23,11 @@ desktop_DATA += mate-wm.desktop
endif
%.desktop: %.desktop.in Makefile
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) sed '/^# Translators/d' < $< > $@
+endif
gsettingsschema_in_files = org.mate.session.gschema.xml.in
gsettings_SCHEMAS = $(gsettingsschema_in_files:.xml.in=.xml)