summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2013-11-08 18:46:33 -0800
committerStefano Karapetsas <[email protected]>2013-11-08 18:46:33 -0800
commit622ff703158394e73f6dae8377b1f6d3f26f79e3 (patch)
treea80168b2ca4dc8546c195581ec3144f8f3fc514f /Makefile.am
parentb4d8c8eba2352420d59787076a79a138e06145d3 (diff)
parentf25ab14084285273868b9e83e5b0065a59e724d7 (diff)
downloadmate-settings-daemon-622ff703158394e73f6dae8377b1f6d3f26f79e3.tar.bz2
mate-settings-daemon-622ff703158394e73f6dae8377b1f6d3f26f79e3.tar.xz
Merge pull request #54 from infirit/1.6
Fixes and cleanups
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 14617a5..2d42695 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
NULL =
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
SUBDIRS = \
mate-settings-daemon \
plugins \
@@ -14,3 +16,17 @@ EXTRA_DIST = \
DISTCLEANFILES = \
$(NULL)
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ (GIT_DIR=$(top_srcdir)/.git \
+ ./missing --run git log --stat -M -C --name-status --date=short --no-color) | \
+ fmt --split-only > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi