summaryrefslogtreecommitdiff
path: root/plugins/background/Makefile.am
diff options
context:
space:
mode:
authororbea <[email protected]>2024-03-17 10:14:22 -0700
committerLuke from DC <[email protected]>2024-08-15 17:59:01 +0000
commit1462391e13a746157924ce80b14d7fd68cd48430 (patch)
treec18c9e58cbac626843813576ca02c8e50bce54ed /plugins/background/Makefile.am
parent2194cb268ddc7289ba7f7ec36544527c238fa797 (diff)
downloadmate-settings-daemon-1462391e13a746157924ce80b14d7fd68cd48430.tar.bz2
mate-settings-daemon-1462391e13a746157924ce80b14d7fd68cd48430.tar.xz
plugins: add missing x11 linker flags
Many of the plugins depend on the libX11 and libXi linker flags, but they are missing. With GNU libtool the -no-undefined flag is silently ignored so the build succeeds, but with slibtool is correctly sets -Wl,--no-undefined in the linker flags. Gentoo issue: https://bugs.gentoo.org/922326
Diffstat (limited to 'plugins/background/Makefile.am')
-rw-r--r--plugins/background/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/plugins/background/Makefile.am b/plugins/background/Makefile.am
index ac32ceb..b2ab685 100644
--- a/plugins/background/Makefile.am
+++ b/plugins/background/Makefile.am
@@ -58,6 +58,7 @@ libbackground_la_LDFLAGS = \
libbackground_la_LIBADD = \
$(SETTINGS_PLUGIN_LIBS) \
$(MATE_DESKTOP_LIBS) \
+ $(X11_LIBS) \
$(NULL)
plugin_in_files = \