summaryrefslogtreecommitdiff
path: root/plugins/xsettings/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-12-13 14:50:54 +0100
committerinfirit <[email protected]>2014-12-13 18:32:16 +0100
commit5561f9707602bca1e768a58f9c2ff30d70586ead (patch)
tree2532a696bb619c85e424d09ab8522ebf3d6b3d7f /plugins/xsettings/Makefile.am
parentfc2923e36d4ac7a3ec2cf848e168d82cf77c0b16 (diff)
downloadmate-settings-daemon-5561f9707602bca1e768a58f9c2ff30d70586ead.tar.bz2
mate-settings-daemon-5561f9707602bca1e768a58f9c2ff30d70586ead.tar.xz
xsettings: Make fontconfig a hard dependency
It's required lower down the GTK+ stack on Unices anyway, so there's no point in making it an option. Taken from GSD commit: f6257d7e81aaa79dcd7430c0de092145f64f6146 From: Bastien Nocera <[email protected]>
Diffstat (limited to 'plugins/xsettings/Makefile.am')
-rw-r--r--plugins/xsettings/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/plugins/xsettings/Makefile.am b/plugins/xsettings/Makefile.am
index 87f0eab..c4d0520 100644
--- a/plugins/xsettings/Makefile.am
+++ b/plugins/xsettings/Makefile.am
@@ -13,6 +13,8 @@ libxsettings_la_SOURCES = \
xsettings-common.c \
xsettings-manager.h \
xsettings-manager.c \
+ fontconfig-monitor.h \
+ fontconfig-monitor.c \
$(NULL)
libxsettings_la_CPPFLAGS = \
@@ -22,6 +24,7 @@ libxsettings_la_CPPFLAGS = \
libxsettings_la_CFLAGS = \
$(SETTINGS_PLUGIN_CFLAGS) \
+ $(FONTCONFIG_CFLAGS) \
$(AM_CFLAGS)
libxsettings_la_LDFLAGS = \
@@ -30,20 +33,9 @@ libxsettings_la_LDFLAGS = \
libxsettings_la_LIBADD = \
$(SETTINGS_PLUGIN_LIBS) \
+ $(FONTCONFIG_LIBS) \
$(NULL)
-if HAVE_FONTCONFIG
-libxsettings_la_SOURCES += \
- fontconfig-monitor.h \
- fontconfig-monitor.c \
- $(NULL)
-libxsettings_la_CFLAGS += \
- $(FONTCONFIG_CFLAGS)
-libxsettings_la_LIBADD += \
- $(FONTCONFIG_LIBS)
-endif
-
-
plugin_in_files = \
xsettings.mate-settings-plugin.in \
$(NULL)