summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac99
1 files changed, 50 insertions, 49 deletions
diff --git a/configure.ac b/configure.ac
index cf4f72a..571817a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
AC_PREREQ([2.60])
m4_define([msd_api_version_major],[1])
-m4_define([msd_api_version_minor],[25])
+m4_define([msd_api_version_minor],[28])
m4_define([msd_api_version_micro],[0])
m4_define([msd_api_version],
[msd_api_version_major.msd_api_version_minor.msd_api_version_micro])
@@ -35,7 +35,7 @@ AC_CONFIG_HEADERS([config.h])
AM_GNU_GETTEXT_VERSION([0.19.8])
AM_GNU_GETTEXT([external])
-GETTEXT_PACKAGE=mate-settings-daemon
+GETTEXT_PACKAGE=AC_PACKAGE_NAME
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of default gettext domain])
@@ -53,10 +53,10 @@ dnl - Dependencies
dnl ---------------------------------------------------------------------------
DBUS_GLIB_REQUIRED_VERSION=0.74
-GLIB_REQUIRED_VERSION=2.50.0
+GLIB_REQUIRED_VERSION=2.58.0
GIO_REQUIRED_VERSION=2.50.0
GTK_REQUIRED_VERSION=3.22.0
-MATE_DESKTOP_REQUIRED_VERSION=1.25.0
+MATE_DESKTOP_REQUIRED_VERSION=1.27.1
LIBMATEKBD_REQUIRED_VERSION=1.17.0
LIBNOTIFY_REQUIRED_VERSION=0.7.0
LIBATSPI_REQUIRED_VERSION=2.0
@@ -68,13 +68,11 @@ PKG_CHECK_MODULES(SETTINGS_DAEMON,
gio-2.0 >= $GIO_REQUIRED_VERSION
gmodule-2.0
gthread-2.0
- dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
)
PKG_CHECK_MODULES(SETTINGS_PLUGIN,
gtk+-3.0 >= $GTK_REQUIRED_VERSION
gio-2.0 >= $GIO_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
)
MSD_PLUGIN_LDFLAGS="-export_dynamic -module -avoid-version -no-undefined"
@@ -88,6 +86,7 @@ AC_SUBST([MSD_PLUGIN_LDFLAGS])
PKG_CHECK_MODULES(DCONF, dconf >= 0.13.4)
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+AC_PATH_PROG(GDBUS_CODEGEN, gdbus-codegen)
GLIB_GSETTINGS
@@ -102,7 +101,7 @@ dnl ---------------------------------------------------------------------------
have_libnotify=no
AC_ARG_WITH(libnotify,
- AC_HELP_STRING([--without-libnotify], [Disable notifications (default: auto)]),
+ AS_HELP_STRING([--without-libnotify], [Disable notifications (default: auto)]),
with_libnotify=$withval, with_libnotify=auto)
if test "x$with_libnotify" != "xno"; then
@@ -142,10 +141,10 @@ dnl ---------------------------------------------------------------------------
dnl - Are we specifying a different dbus root ?
AC_ARG_WITH(dbus-sys,
- [AC_HELP_STRING([--with-dbus-sys=<dir>],
+ [AS_HELP_STRING([--with-dbus-sys=<dir>],
[where D-BUS system.d directory is])])
AC_ARG_WITH(dbus-services,
- [AC_HELP_STRING([--with-dbus-services=<dir>],
+ [AS_HELP_STRING([--with-dbus-services=<dir>],
[where D-BUS services directory is])])
if ! test -z "$with_dbus_sys" ; then
DBUS_SYS_DIR="$with_dbus_sys"
@@ -230,7 +229,7 @@ dnl ---------------------------------------------------------------------------
have_pulse=false
AC_ARG_ENABLE(pulse,
- AC_HELP_STRING([--disable-pulse], [Disable PulseAudio support]),
+ AS_HELP_STRING([--disable-pulse], [Disable PulseAudio support]),
[case "${enableval}" in
yes) WANT_PULSE=yes ;;
no) WANT_PULSE=no ;;
@@ -252,7 +251,7 @@ AC_SUBST(PULSE_LIBS)
have_libcanberra=no
AC_ARG_WITH(libcanberra,
- AC_HELP_STRING([--without-libcanberra], [Disable sound events (default: auto)]),
+ AS_HELP_STRING([--without-libcanberra], [Disable sound events (default: auto)]),
with_libcanberra=$withval, with_libcanberra=auto)
if test "x$with_libcanberra" != "xno"; then
@@ -268,7 +267,7 @@ AC_SUBST(LIBCANBERRA_LIBS)
have_libmatemixer=no
AC_ARG_WITH(libmatemixer,
- AC_HELP_STRING([--without-libmatemixer], [Disable volume event handling (default: auto)]),
+ AS_HELP_STRING([--without-libmatemixer], [Disable volume event handling (default: auto)]),
with_libmatemixer=$withval, with_libmatemixer=auto)
if test "x$with_libmatemixer" != "xno"; then
@@ -295,7 +294,7 @@ dnl smartcard section
dnl ==============================================
have_smartcard_support=false
AC_ARG_ENABLE(smartcard-support,
- AC_HELP_STRING([--disable-smartcard-support],
+ AS_HELP_STRING([--disable-smartcard-support],
[turn off smartcard support]),
[case "${enableval}" in
yes) WANT_SMARTCARD_SUPPORT=yes ;;
@@ -317,7 +316,7 @@ AC_SUBST(NSS_CFLAGS)
AC_SUBST(NSS_LIBS)
AC_ARG_WITH(nssdb,
- AC_HELP_STRING([--with-nssdb],
+ AS_HELP_STRING([--with-nssdb],
[where system NSS database is]))
NSS_DATABASE=""
@@ -340,7 +339,6 @@ AC_SUBST(NSS_DATABASE)
# ---------------------------------------------------------------------------
POLKIT_REQUIRED=0.97
-DBUS_REQUIRED=1.10.0
# PolicyKit detection; defaults to 'auto' (use it if it's available)
#
@@ -356,7 +354,7 @@ if test "x$enable_polkit" = "xno" ; then
HAVE_POLKIT=no
else
HAVE_POLKIT=no
- PKG_CHECK_MODULES(POLKIT, polkit-gobject-1 >= $POLKIT_REQUIRED dbus-1 >= $DBUS_REQUIRED, HAVE_POLKIT=yes, HAVE_POLKIT=no)
+ PKG_CHECK_MODULES(POLKIT, polkit-gobject-1 >= $POLKIT_REQUIRED, HAVE_POLKIT=yes, HAVE_POLKIT=no)
if test "x$enable_polkit" = "xyes" -a "x$HAVE_POLKIT" = "xno" ; then
AC_MSG_ERROR(PolicyKit support explicity enabled but not available)
@@ -389,7 +387,7 @@ AM_CONDITIONAL(BUILD_RFKILL, [test x"$enable_rfkill" = x"yes"])
# Enable Profiling
# ---------------------------------------------------------------------------
AC_ARG_ENABLE(profiling,
- [AC_HELP_STRING([--enable-profiling],
+ [AS_HELP_STRING([--enable-profiling],
[turn on profiling])],
, enable_profiling=no)
if test "x$enable_profiling" = "xyes"; then
@@ -407,7 +405,7 @@ dnl ---------------------------------------------------------------------------
dnl - Finish
dnl ---------------------------------------------------------------------------
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
mate-settings-daemon/Makefile
plugins/Makefile
@@ -463,43 +461,46 @@ data/org.mate.SettingsDaemon.plugins.xsettings.gschema.xml
data/org.mate.SettingsDaemon.plugins.gschema.xml
po/Makefile.in
])
+AC_OUTPUT
dnl ---------------------------------------------------------------------------
dnl - Show summary
dnl ---------------------------------------------------------------------------
echo "
- mate-settings-daemon $VERSION
- =============================
-
- prefix: ${prefix}
- exec_prefix: ${exec_prefix}
- libdir: ${libdir}
- bindir: ${bindir}
- sbindir: ${sbindir}
- sysconfdir: ${sysconfdir}
- sysconfsubdir: ${sysconfsubdir}
- localstatedir: ${localstatedir}
- plugindir: ${plugindir}
- datadir: ${datadir}
- source code location: ${srcdir}
- compiler: ${CC}
- cflags: ${CFLAGS}
- warning cflags: ${WARN_CFLAGS}
- Maintainer mode: ${USE_MAINTAINER_MODE}
-
- dbus-1 system.d dir: ${DBUS_SYS_DIR}
- PolicyKit support: ${HAVE_POLKIT}
-
- PulseAudio support: ${have_pulse}
- Libnotify support: ${have_libnotify}
- Libatspi support: ${have_libatspi}
- Libcanberra support: ${have_libcanberra}
- Libmatemixer support: ${have_libmatemixer}
- Smartcard support: ${have_smartcard_support}
- RFKill support: ${enable_rfkill}
+Configure summary:
+
+ ${PACKAGE_STRING}
+ `echo $PACKAGE_STRING | sed "s/./=/g"`
+
+ prefix ..................: ${prefix}
+ exec_prefix .............: ${exec_prefix}
+ libdir ..................: ${libdir}
+ bindir ..................: ${bindir}
+ sbindir .................: ${sbindir}
+ sysconfdir...............: ${sysconfdir}
+ sysconfsubdir ...........: ${sysconfsubdir}
+ localstatedir............: ${localstatedir}
+ plugindir ...............: ${plugindir}
+ datadir..................: ${datadir}
+ source code location ....: ${srcdir}
+ compiler.................: ${CC}
+ cflags ..................: ${CFLAGS}
+ warning cflags ..........: ${WARN_CFLAGS}
+ Maintainer mode .........: ${USE_MAINTAINER_MODE}
+
+ dbus-1 system.d dir .....: ${DBUS_SYS_DIR}
+ PolicyKit support .......: ${HAVE_POLKIT}
+
+ PulseAudio support ......: ${have_pulse}
+ Libnotify support .......: ${have_libnotify}
+ Libatspi support ........: ${have_libatspi}
+ Libcanberra support .....: ${have_libcanberra}
+ Libmatemixer support ....: ${have_libmatemixer}
+ Smartcard support .......: ${have_smartcard_support}
+ RFKill support ..........: ${enable_rfkill}
${NSS_DATABASE:+\
- System nssdb: ${NSS_DATABASE}
+ System nssdb ............: ${NSS_DATABASE}
}\
- Profiling support: ${enable_profiling}
+ Profiling support .......: ${enable_profiling}
"