summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorinfirit <[email protected]>2013-11-08 22:36:10 +0100
committerinfirit <[email protected]>2013-11-08 22:36:10 +0100
commit7784304322821afd5b40728c27f40b17fbb330cb (patch)
treef11875e90226e7172b3ee95ac0670eee5e2c3d4e /Makefile.am
parent64f551f2ac731b5b863b2255076681847aabb3ce (diff)
downloadmate-system-monitor-7784304322821afd5b40728c27f40b17fbb330cb.tar.bz2
mate-system-monitor-7784304322821afd5b40728c27f40b17fbb330cb.tar.xz
Add dist-hook for Changelog creation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 93c8a92..6084b1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,3 +29,17 @@ DISTCLEANFILES = \
mate-system-monitor.desktop
DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper
+
+dist-hook:
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ (GIT_DIR=$(top_srcdir)/.git \
+ ./missing --run git log --stat -M -C --name-status --date=short --no-color) | \
+ fmt --split-only > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi