summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2014-12-18 22:24:30 +0100
committerinfirit <[email protected]>2014-12-18 22:29:00 +0100
commit21eeae3b6a844222365b873a8826001af33f1e97 (patch)
treee990971ea17c71652b63f4de14c217a33997eb3b /configure.ac
parentba876f3e3791741d977dd72e16b760c39a71e047 (diff)
downloadmate-system-monitor-21eeae3b6a844222365b873a8826001af33f1e97.tar.bz2
mate-system-monitor-21eeae3b6a844222365b873a8826001af33f1e97.tar.xz
systemd: add process view columns for unit, session, seat, owner
This (optionally) hooks up the system monitor with systemd, adding four new columns to the process view: 1. Unit (i.e. the service name a system process belongs to) 2. Session (i.e. the login session a user process belongs to) 3. Seat (i.e. the physical seat the session of the process belongs to, only for multi-seat environments) 4. Owner (i.e. the user a process belongs to, which is not influenced by temporary UID changes like sudo/su/suid. This patch also enables that the Unit column is shown by default. If systemd is not around at runtime or at compile time none of the four new columns are shown. Taken from GSM commit: df292c0fb07d73448fe26048118b127719750729 From: Lennart Poettering <[email protected]> Gnome bug: https://bugzilla.gnome.org/show_bug.cgi?id=667829
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10ce372..0edfd3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,17 @@ AC_ARG_WITH([gtk],
PKG_CHECK_MODULES(GMODULE,gmodule-2.0,[GMODULE_ADD="gmodule-2.0"],[GMODULE_ADD=""])
PKG_CHECK_MODULES(PROCMAN,$GMODULE_ADD glib-2.0 >= $GLIB_REQUIRED libgtop-2.0 >= $LIBGTOP_REQUIRED libwnck-$LIBWNCK_API_VERSION >= $LIBWNCK_REQUIRED gtk+-$GTK_API_VERSION >= $GTK_REQUIRED mate-icon-theme >= $MATE_ICON_THEME_REQUIRED gtkmm-$GTKMM_API_VERSION >= $GTKMM_REQUIRED libxml-2.0 >= $LIBXML_REQUIRED librsvg-2.0 >= $RSVG_REQUIRED glibmm-2.4 >= $GLIBMM_REQUIRED giomm-2.4 >= $GIOMM_REQUIRED)
+have_systemd=no
+AC_ARG_ENABLE(systemd, AS_HELP_STRING([--disable-systemd], [disable systemd support]))
+if test "x$enable_systemd" != "xno"; then
+ PKG_CHECK_MODULES(SYSTEMD, [ libsystemd-daemon libsystemd-login ],
+ [AC_DEFINE(HAVE_SYSTEMD, 1, [Define if systemd is available]) have_systemd=yes], have_systemd=no)
+ if test "x$have_systemd" = xno -a "x$enable_systemd" = xyes; then
+ AC_MSG_ERROR([*** systemd support requested but libraries not found])
+ fi
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test "$have_systemd" = "yes"])
+
# Compiler warnings
MATE_COMPILE_WARNINGS([maximum])
@@ -126,4 +137,5 @@ Configuration:
CXXFLAGS: ${CXXFLAGS}
Gtk+ Version: ${GTK_API_VERSION}
Maintainer mode: ${USE_MAINTAINER_MODE}
+ Systemd support: ${have_systemd}
"