summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorinfirit <[email protected]>2015-09-08 15:38:14 +0200
committerinfirit <[email protected]>2015-09-08 15:38:26 +0200
commitf814590318fbf3ac4ea319c61901f4bdbdaf94e8 (patch)
treef55cea6a9af0439f2ca855fcb036d95deed36c6b /configure.ac
parent9c159beee589a225cfd7d7d9aede5a3b7948e9d7 (diff)
downloadmate-system-monitor-f814590318fbf3ac4ea319c61901f4bdbdaf94e8.tar.bz2
mate-system-monitor-f814590318fbf3ac4ea319c61901f4bdbdaf94e8.tar.xz
define max/min version of GLib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f1c250..833cec1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,12 @@ SYSTEMD_REQUIRED=38
# systemd v43 used the C++ keyword 'class' as a function parameter. This breaks the build for C++ programs.
SYSTEMD_EXCLUDED=43
+# GLib min/max required versions
+AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs added after GLib 2.36])
+AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_36],
+ [Warn on use of APIs deprecated before GLib 2.36])
+
AC_MSG_CHECKING([which gtk+ version to compile against])
AC_ARG_WITH([gtk],
[AS_HELP_STRING([--with-gtk=2.0|3.0],[which gtk+ version to compile against (default: 2.0)])],