summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorzhuyaliang <[email protected]>2021-10-07 21:36:04 +0800
committerraveit65 <[email protected]>2021-10-15 21:33:59 +0200
commitf1c1e72d96c11194ff89752a4e22b6edffa75666 (patch)
tree66b1ef28de295faa53273f025bb4ed0bdf8da733 /src/meson.build
parentddeb66b5af61a5367c8b72a5e5845317e82b62a4 (diff)
downloadmate-system-monitor-f1c1e72d96c11194ff89752a4e22b6edffa75666.tar.bz2
mate-system-monitor-f1c1e72d96c11194ff89752a4e22b6edffa75666.tar.xz
Add meson build support
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build103
1 files changed, 103 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..4810ad7
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,103 @@
+system_monitor_sources = []
+
+msm_resource = gnome.compile_resources(
+ 'msm',
+ 'msm.gresource.xml',
+ source_dir: 'src',
+)
+
+system_monitor_sources += [
+ 'argv.cpp',
+ 'procman.cpp',
+ 'interface.cpp',
+ 'callbacks.cpp',
+ 'load-graph.cpp',
+ 'proctable.cpp',
+ 'prettytable.cpp',
+ 'util.cpp',
+ 'procactions.cpp',
+ 'procdialogs.cpp',
+ 'memmaps.cpp',
+ 'openfiles.cpp',
+ 'procproperties.cpp',
+ 'smooth_refresh.cpp',
+ 'disks.cpp',
+ 'selinux.cpp',
+ 'cgroups.cpp',
+ 'procman_gksu.cpp',
+ 'procman_pkexec.cpp',
+ 'sysinfo.cpp',
+ 'lsof.cpp',
+ 'selection.cpp',
+ 'settings-keys.cpp',
+ 'iconthemewrapper.cpp',
+ 'procman-app.cpp',
+ 'gsm_color_button.c',
+ msm_resource
+]
+
+system_monitor_headers = [
+ 'argv.h',
+ 'callbacks.h',
+ 'cgroups.h',
+ 'defaulttable.h',
+ 'disks.h',
+ 'gsm_color_button.h',
+ 'iconthemewrapper.h',
+ 'interface.h',
+ 'load-graph.h',
+ 'lsof.h',
+ 'memmaps.h',
+ 'openfiles.h',
+ 'prettytable.h',
+ 'procactions.h',
+ 'procdialogs.h',
+ 'procman-app.h',
+ 'procman_gksu.h',
+ 'procman.h',
+ 'procman_pkexec.h',
+ 'procproperties.h',
+ 'proctable.h',
+ 'selection.h',
+ 'selinux.h',
+ 'settings-keys.h',
+ 'smooth_refresh.h',
+ 'sysinfo.h',
+ 'util.h',
+]
+
+msm_schemas = configure_file(
+ input : 'org.mate.system-monitor.gschema.xml.in',
+ output: 'org.mate.system-monitor.gschema.xml',
+ configuration: dataconf,
+ install: true,
+ install_dir: join_paths(get_option('datadir'), 'glib-2.0', 'schemas'),
+)
+
+msm_gsettings = gnome.mkenums('org.mate.mate-system-monitor.enums.xml',
+ sources: system_monitor_headers,
+ comments: '<!-- @comment@ -->',
+ fhead: '<schemalist>',
+ vhead: ' <@type@ id=\'org.mate.mate-system-monitor.@EnumName@\'>',
+ vprod: ' <value nick=\'@valuenick@\' value=\'@valuenum@\'/>',
+ vtail: ' </@type@>',
+ ftail: '</schemalist>',
+ install_header: true,
+ install_dir: join_paths(get_option('datadir'), 'glib-2.0', 'schemas'),
+)
+
+executable(meson.project_name(),
+ system_monitor_sources,
+ include_directories: rootInclude,
+ dependencies: [
+ gmodule,
+ gtkmm,
+ libgtop,
+ libsystemd,
+ libwnck,
+ libxml,
+ librsvg,
+ ],
+ install: true,
+ install_dir : get_option('bindir')
+)