summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2020-06-18 10:58:17 +0800
committerraveit65 <[email protected]>2020-06-28 09:26:20 +0200
commitf8d2c7bdcc6fd37c37dcb39ed61f7c6cc5dcb962 (patch)
tree320795b9089497ecfc244a2a01c27757828ff732 /configure.ac
parent6f5e03e2a70b0d2b3f88c308ca7d7020d50728c8 (diff)
downloadmate-terminal-f8d2c7bdcc6fd37c37dcb39ed61f7c6cc5dcb962.tar.bz2
mate-terminal-f8d2c7bdcc6fd37c37dcb39ed61f7c6cc5dcb962.tar.xz
use libegg submodules
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 51f6149..9eac461 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,7 +66,7 @@ AC_ARG_ENABLE(smclient,
have_sm=no
if test "x$enable_smclient" != "xno"; then
- PKG_CHECK_MODULES(SMCLIENT, sm >= 1.0.0 ice >= 1.0.0, have_sm=yes, [
+ PKG_CHECK_MODULES(LIBEGG, sm >= 1.0.0 ice >= 1.0.0 gtk+-3.0, have_sm=yes, [
if test "x$enable_smclient" = "xyes"; then
AC_MSG_ERROR([smclient enabled but SM library not found])
fi
@@ -79,8 +79,8 @@ if test "x$have_sm" = "xyes"; then
AC_DEFINE(HAVE_SMCLIENT, 1, [Have the SM development library])
fi
-AC_SUBST([SMCLIENT_CFLAGS])
-AC_SUBST([SMCLIENT_LIBS])
+AC_SUBST([LIBEGG_CFLAGS])
+AC_SUBST([LIBEGG_LIBS])
# *****
# GSettings
@@ -148,6 +148,8 @@ AC_CONFIG_FILES([
Makefile
mate-terminal.desktop.in
src/Makefile
+src/mate-submodules/Makefile
+src/mate-submodules/libegg/Makefile
src/org.mate.terminal.gschema.xml
src/terminal-version.h
help/Makefile