summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWu Xiaotian <[email protected]>2020-06-18 10:58:17 +0800
committerraveit65 <[email protected]>2020-06-28 09:26:20 +0200
commitf8d2c7bdcc6fd37c37dcb39ed61f7c6cc5dcb962 (patch)
tree320795b9089497ecfc244a2a01c27757828ff732 /src/Makefile.am
parent6f5e03e2a70b0d2b3f88c308ca7d7020d50728c8 (diff)
downloadmate-terminal-f8d2c7bdcc6fd37c37dcb39ed61f7c6cc5dcb962.tar.bz2
mate-terminal-f8d2c7bdcc6fd37c37dcb39ed61f7c6cc5dcb962.tar.xz
use libegg submodules
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 053f557..1e58044 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,13 @@
NULL =
+SUBDIRS = $(NULL)
+
if ENABLE_SKEY
-SUBDIRS = skey
+SUBDIRS += skey
+endif
+
+if ENABLE_SMCLIENT
+SUBDIRS += mate-submodules
endif
bin_PROGRAMS = mate-terminal
@@ -65,6 +71,7 @@ endif
nodist_mate_terminal_SOURCES= $(BUILT_SOURCES)
mate_terminal_CPPFLAGS = \
+ -I$(top_srcdir)/src/mate-submodules/libegg \
-DTERMINAL_COMPILATION \
-DTERMINAL_RESOURCES_PATH_PREFIX="\"/org/mate/terminal\"" \
-DTERM_DATADIR="\"$(datadir)\"" \
@@ -96,18 +103,7 @@ mate_terminal_LDADD += \
endif
if ENABLE_SMCLIENT
-mate_terminal_SOURCES += \
- eggdesktopfile.c \
- eggdesktopfile.h \
- eggsmclient.c \
- eggsmclient.h \
- eggsmclient-private.h \
- eggsmclient-xsmp.c \
- $(NULL)
-
-mate_terminal_CFLAGS += $(SMCLIENT_CFLAGS)
-mate_terminal_CPPFLAGS += -DEGG_SM_CLIENT_BACKEND_XSMP
-mate_terminal_LDADD += $(SMCLIENT_LIBS)
+mate_terminal_LDADD += $(top_builddir)/src/mate-submodules/libegg/libegg.la
endif
TYPES_H_FILES = \