summaryrefslogtreecommitdiff
path: root/desktop-themes/YaruGreen/Makefile.am
diff options
context:
space:
mode:
authorblue-devil-93 <[email protected]>2021-06-24 10:32:21 +0200
committerGitHub <[email protected]>2021-06-24 10:32:21 +0200
commit9bf6f4ec2f77fd09a12ba2b68416e81a13b4ca3d (patch)
tree497fa90cd62785e4c9a522d265f323598fe575d8 /desktop-themes/YaruGreen/Makefile.am
parentfb195c9951cd9d87cd650f1cb901dbfc5966ab04 (diff)
downloadmate-themes-9bf6f4ec2f77fd09a12ba2b68416e81a13b4ca3d.tar.bz2
mate-themes-9bf6f4ec2f77fd09a12ba2b68416e81a13b4ca3d.tar.xz
Propose a different traditional ok implentation (#290)
* tr * Propose another Traditonal Ok implementation based on Yaru * Makefile * fix makefile * remove whitespace+ * remove trailing whitespaces * rename it to traditionalok * move Theme to yaruok * Fix regression in mate appearance yaruok * Sync with official branch * readd traditionalokf * fix YaruOK case mismatch * improve tabs on gtk4 * fix Makefile.am * Add YaruGreen * Fix YaruGreen GTK3 * Fix Build - first try * Fix Build - second try * Fix Build - third try * improve colors of yaru green, decrease tab size * import scrollbar code from traditional green to yaru green * fix build * Tab_alignment_fix_for_yaru_green * add panel grip * decrease_tab_size fix_panel fix_link_color * sync_yru_ok_with_green * addpanel_gripper_to yaru * darken yarugreen scrollbar as requested * decrease border radius for popover on yaru grren and ok * decrease border radius for popover on yaru grren and ok . * fiy overlay - first try * fix osd colors * improve tabs and panel grabber * decrease popover and menu radius to 2px * fix mate-calc * fix mate-calc.
Diffstat (limited to 'desktop-themes/YaruGreen/Makefile.am')
-rw-r--r--desktop-themes/YaruGreen/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/desktop-themes/YaruGreen/Makefile.am b/desktop-themes/YaruGreen/Makefile.am
new file mode 100644
index 00000000..187b2ff0
--- /dev/null
+++ b/desktop-themes/YaruGreen/Makefile.am
@@ -0,0 +1,20 @@
+THEME_NAME = YaruGreen
+
+theme_in_files = index.theme.in
+themedir = $(datadir)/themes/$(THEME_NAME)
+theme_DATA = COPYING index.theme
+
+%.theme: %.theme.in
+if USE_NLS
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp -f $< $@
+endif
+
+SUBDIRS = \
+ gtk-2.0 \
+ gtk-3.0 \
+ metacity-1
+
+CLEANFILES = index.theme
+EXTRA_DIST = $(theme_in_files)