summaryrefslogtreecommitdiff
path: root/icon-themes/HighContrast-SVG/scalable/devices/Makefile.am
diff options
context:
space:
mode:
authorPerberos <[email protected]>2011-12-01 23:42:46 -0300
committerPerberos <[email protected]>2011-12-01 23:42:46 -0300
commitead8ef613ce66d51399a87d225b4cd52c6c7983e (patch)
tree28331e03ae7cced58068fc2a35dbf127d109a73e /icon-themes/HighContrast-SVG/scalable/devices/Makefile.am
downloadmate-themes-ead8ef613ce66d51399a87d225b4cd52c6c7983e.tar.bz2
mate-themes-ead8ef613ce66d51399a87d225b4cd52c6c7983e.tar.xz
moving from https://github.com/perberos/mate-desktop-environment
Diffstat (limited to 'icon-themes/HighContrast-SVG/scalable/devices/Makefile.am')
-rw-r--r--icon-themes/HighContrast-SVG/scalable/devices/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/icon-themes/HighContrast-SVG/scalable/devices/Makefile.am b/icon-themes/HighContrast-SVG/scalable/devices/Makefile.am
new file mode 100644
index 00000000..a7ff6bf8
--- /dev/null
+++ b/icon-themes/HighContrast-SVG/scalable/devices/Makefile.am
@@ -0,0 +1,60 @@
+themedir = $(datadir)/icons/HighContrast-SVG
+size = scalable
+context = devices
+
+icondir = $(themedir)/$(size)/$(context)
+
+icon_DATA = \
+ audio-input-microphone.svg \
+ battery.svg \
+ camera-photo.svg \
+ camera-video.svg \
+ camera-web.svg \
+ computer.svg \
+ drive-harddisk.svg \
+ drive-optical.svg \
+ drive-removable-media.svg \
+ input-keyboard.svg \
+ input-mouse.svg \
+ input-tablet.svg \
+ media-flash.svg \
+ media-floppy.svg \
+ media-optical.svg \
+ media-tape.svg \
+ multimedia-player.svg \
+ network-wired.svg \
+ network-wireless.svg \
+ pda.svg \
+ phone.svg \
+ printer.svg \
+ scanner.svg \
+ video-display.svg
+
+placeholder_FILES = \
+ audio-card.svg \
+ input-gaming.svg \
+ modem.svg
+
+if PLACEHOLDERS
+icon_DATA += $(placeholder_FILES)
+endif
+
+EXTRA_DIST = \
+ $(icon_DATA) \
+ $(placeholder_FILES)
+
+if LEGACY_ICON_MAPPING
+install-data-local: install-iconDATA
+ (cd $(DESTDIR)$(themedir)/$(size) && $(ICONMAP) -c $(context))
+endif
+
+
+uninstall-symlinks:
+ list=`ls $(DESTDIR)$(themedir)/$(size)/$(context)`; \
+ for p in $$list; do \
+ if test -h $(DESTDIR)$(themedir)/$(size)/$(context)/$$p; then \
+ rm -f $(DESTDIR)$(themedir)/$(size)/$(context)/$$p; \
+ fi; \
+ done
+
+uninstall-am: uninstall-iconDATA uninstall-symlinks