summaryrefslogtreecommitdiff
path: root/cursor-themes/mate-black/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cursor-themes/mate-black/Makefile.am')
-rw-r--r--cursor-themes/mate-black/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/cursor-themes/mate-black/Makefile.am b/cursor-themes/mate-black/Makefile.am
index 3bf75550..0c379c86 100644
--- a/cursor-themes/mate-black/Makefile.am
+++ b/cursor-themes/mate-black/Makefile.am
@@ -1,16 +1,17 @@
-THEME_NAME=mate-black
-THEME_IN_FILES=index.theme.in
+THEME_NAME = mate-black
themedir = $(datadir)/icons/$(THEME_NAME)
+theme_in_files = index.theme.in
+theme_DATA = $(theme_in_files:.theme.in=.theme)
-theme_DATA = \
- index.theme
-
-$(theme_DATA): $(THEME_IN_FILES)
+%.theme: %.theme.in
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp -f $< $@
+endif
-SUBDIRS = \
- cursors
+SUBDIRS = cursors
-DISTCLEANFILES = index.theme
-EXTRA_DIST = index.theme.in
+CLEANFILES = $(theme_DATA)
+EXTRA_DIST = $(theme_in_files)