summaryrefslogtreecommitdiff
path: root/icon-themes/ContrastHigh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'icon-themes/ContrastHigh/Makefile.am')
-rw-r--r--icon-themes/ContrastHigh/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/icon-themes/ContrastHigh/Makefile.am b/icon-themes/ContrastHigh/Makefile.am
index 1d050bd7..bb184747 100644
--- a/icon-themes/ContrastHigh/Makefile.am
+++ b/icon-themes/ContrastHigh/Makefile.am
@@ -1,5 +1,3 @@
-indexthemedir = $(datadir)/icons/ContrastHigh/
-
SUBDIRS = \
16x16 \
22x22 \
@@ -9,6 +7,16 @@ SUBDIRS = \
256x256 \
scalable
+indexthemedir = $(datadir)/icons/ContrastHigh
indextheme_DATA = index.theme
+indextheme_in_files = $(indextheme_DATA:.theme=.theme.in)
+
+%.theme: %.theme.in
+if USE_NLS
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp -f $< $@
+endif
-EXTRA_DIST= $(indextheme_DATA)
+CLEANFILES = $(indextheme_DATA)
+EXTRA_DIST = $(indextheme_in_files)