summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 90be13d..a340ef6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -31,6 +31,7 @@ INCLUDES= \
-I$(top_builddir) \
$(EXTENSION_CFLAGS) \
$(USER_SHARE_CFLAGS) \
+ $(BLUETOOTH_CFLAGS) \
$(USER_SHARE_CONFIG_CFLAGS) \
$(X_CFLAGS)
@@ -41,10 +42,6 @@ mate_user_share_SOURCES = \
user_share-private.c \
http.c \
http.h \
- obexftp.c \
- obexftp.h \
- obexpush.c \
- obexpush.h \
$(MARSHALFILES)
mate_user_share_LDADD = \
@@ -53,6 +50,15 @@ mate_user_share_LDADD = \
$(SELINUX_LIBS) \
$(X_LIBS) $(X_PRE_LIBS) -lX11 $(X_EXTRA_LIBS)
+if USE_BLUETOOTH
+mate_user_share_SOURCES += \
+ obexftp.c \
+ obexftp.h \
+ obexpush.c \
+ obexpush.h
+mate_user_share_LDADD += $(BLUETOOTH_LIBS)
+endif
+
mate_file_share_properties_SOURCES = \
file-share-properties.c \
user_share-private.h \