summaryrefslogtreecommitdiff
path: root/mate-dictionary/src/Makefile.am
diff options
context:
space:
mode:
authorStefano Karapetsas <[email protected]>2011-12-14 10:13:54 +0100
committerStefano Karapetsas <[email protected]>2011-12-14 10:13:54 +0100
commitef0467789bfc8406b57ba553e4d59f4d6c3f9be8 (patch)
tree09d541636a16cb38448fe6183289ebdc3080c1bf /mate-dictionary/src/Makefile.am
downloadmate-utils-ef0467789bfc8406b57ba553e4d59f4d6c3f9be8.tar.bz2
mate-utils-ef0467789bfc8406b57ba553e4d59f4d6c3f9be8.tar.xz
Moved from Mate-Extra repository
Diffstat (limited to 'mate-dictionary/src/Makefile.am')
-rw-r--r--mate-dictionary/src/Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/mate-dictionary/src/Makefile.am b/mate-dictionary/src/Makefile.am
new file mode 100644
index 00000000..ddde3d26
--- /dev/null
+++ b/mate-dictionary/src/Makefile.am
@@ -0,0 +1,82 @@
+NULL =
+
+INCLUDES = \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DUIDATADIR=\""$(datadir)/mate-2.0/ui"\" \
+ -DPKGDATADIR=\""$(datadir)/mate-dictionary"\" \
+ -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ $(NULL)
+
+bin_PROGRAMS = mate-dictionary
+
+if BUILD_GDICT_APPLET
+libexec_PROGRAMS = mate-dictionary-applet
+endif
+
+mate_dictionary_SOURCES = \
+ gdict-about.c \
+ gdict-about.h \
+ gdict-app.c \
+ gdict-app.h \
+ gdict-common.c \
+ gdict-common.h \
+ gdict-pref-dialog.c \
+ gdict-pref-dialog.h \
+ gdict-print.c \
+ gdict-print.h \
+ gdict-sidebar.c \
+ gdict-sidebar.h \
+ gdict-source-dialog.c \
+ gdict-source-dialog.h \
+ gdict-window.c \
+ gdict-window.h \
+ main.c \
+ $(NULL)
+mate_dictionary_CFLAGS = \
+ -I$(top_builddir)/mate-dictionary \
+ -I$(top_srcdir)/mate-dictionary \
+ $(MATE_UTILS_CFLAGS) \
+ $(NULL)
+mate_dictionary_LDADD = \
+ -lm \
+ $(top_builddir)/mate-dictionary/libgdict/libmatedict.la \
+ $(MATE_UTILS_LIBS) \
+ $(NULL)
+
+if BUILD_GDICT_APPLET
+
+mate_dictionary_applet_SOURCES = \
+ gdict-about.c \
+ gdict-about.h \
+ gdict-aligned-window.c \
+ gdict-aligned-window.h \
+ gdict-applet.c \
+ gdict-applet.h \
+ gdict-common.c \
+ gdict-common.h \
+ gdict-pref-dialog.c \
+ gdict-pref-dialog.h \
+ gdict-print.c \
+ gdict-print.h \
+ gdict-sidebar.c \
+ gdict-sidebar.h \
+ gdict-source-dialog.c \
+ gdict-source-dialog.h \
+ $(NULL)
+mate_dictionary_applet_CFLAGS = \
+ -I$(top_builddir)/mate-dictionary \
+ -I$(top_srcdir)/mate-dictionary \
+ $(MATE_UTILS_CFLAGS) \
+ $(APPLET_CFLAGS) \
+ $(NULL)
+mate_dictionary_applet_LDADD = \
+ -lm \
+ $(top_builddir)/mate-dictionary/libgdict/libmatedict.la \
+ $(MATE_UTILS_LIBS) \
+ $(APPLET_LIBS) \
+ $(NULL)
+
+endif # BUILD_GDICT_APPLET