summaryrefslogtreecommitdiff
path: root/mate-dictionary/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-dictionary/src/Makefile.am')
-rw-r--r--mate-dictionary/src/Makefile.am59
1 files changed, 58 insertions, 1 deletions
diff --git a/mate-dictionary/src/Makefile.am b/mate-dictionary/src/Makefile.am
index e8228e6b..8616b3ef 100644
--- a/mate-dictionary/src/Makefile.am
+++ b/mate-dictionary/src/Makefile.am
@@ -27,8 +27,12 @@ AM_CPPFLAGS = \
bin_PROGRAMS = mate-dictionary
if BUILD_GDICT_APPLET
+if ENABLE_IN_PROCESS
+pkglib_LTLIBRARIES = libmate-dictionary-applet.la
+else
libexec_PROGRAMS = mate-dictionary-applet
endif
+endif
mate_dictionary_SOURCES = \
gdict-about.c \
@@ -56,6 +60,7 @@ mate_dictionary_CFLAGS = \
$(GLIB_CFLAGS) \
$(GIO_CFLAGS) \
$(GTK_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
$(WARN_CFLAGS) \
$(NULL)
@@ -65,10 +70,60 @@ mate_dictionary_LDADD = \
$(GLIB_LIBS) \
$(GIO_LIBS) \
$(GTK_LIBS) \
+ $(MATE_DESKTOP_LIBS) \
$(NULL)
if BUILD_GDICT_APPLET
+if ENABLE_IN_PROCESS
+libmate_dictionary_applet_la_SOURCES = \
+ gdict-about.c \
+ gdict-about.h \
+ gdict-aligned-window.c \
+ gdict-aligned-window.h \
+ gdict-applet.c \
+ gdict-applet.h \
+ gdict-common.c \
+ gdict-common.h \
+ gdict-pref-dialog.c \
+ gdict-pref-dialog.h \
+ gdict-print.c \
+ gdict-print.h \
+ gdict-sidebar.c \
+ gdict-sidebar.h \
+ gdict-source-dialog.c \
+ gdict-source-dialog.h \
+ $(NULL)
+
+libmate_dictionary_applet_la_CFLAGS = \
+ -I$(top_builddir)/mate-dictionary \
+ -I$(top_srcdir)/mate-dictionary \
+ $(APPLET_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(GIO_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(NULL)
+
+libmate_dictionary_applet_la_LIBADD = \
+ -lm \
+ $(top_builddir)/mate-dictionary/libgdict/libmatedict.la \
+ $(APPLET_LIBS) \
+ $(GLIB_LIBS) \
+ $(GIO_LIBS) \
+ $(GTK_LIBS) \
+ $(MATE_DESKTOP_LIBS) \
+ $(NULL)
+
+if ENABLE_WAYLAND
+libmate_dictionary_applet_la_LIBADD += \
+ $(WAYLAND_LIBS)
+libmate_dictionary_applet_la_CFLAGS += \
+ $(WAYLAND_CFLAGS)
+endif
+
+else
mate_dictionary_applet_SOURCES = \
gdict-about.c \
gdict-about.h \
@@ -95,6 +150,7 @@ mate_dictionary_applet_CFLAGS = \
$(GLIB_CFLAGS) \
$(GIO_CFLAGS) \
$(GTK_CFLAGS) \
+ $(MATE_DESKTOP_CFLAGS) \
$(WARN_CFLAGS) \
$(NULL)
@@ -105,8 +161,9 @@ mate_dictionary_applet_LDADD = \
$(GLIB_LIBS) \
$(GIO_LIBS) \
$(GTK_LIBS) \
+ $(MATE_DESKTOP_LIBS) \
$(NULL)
-
+endif # ENABLE_IN_PROCESS
endif # BUILD_GDICT_APPLET
-include $(top_srcdir)/git.mk