summaryrefslogtreecommitdiff
path: root/mate-screenshot/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mate-screenshot/data/Makefile.am')
-rw-r--r--mate-screenshot/data/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/mate-screenshot/data/Makefile.am b/mate-screenshot/data/Makefile.am
index b713dc6f..4f54db85 100644
--- a/mate-screenshot/data/Makefile.am
+++ b/mate-screenshot/data/Makefile.am
@@ -1,8 +1,28 @@
+# This file is part of MATE Utils.
+#
+# MATE Utils is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# MATE Utils is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with MATE Utils. If not, see <https://www.gnu.org/licenses/>.
+
mate_screenshotdir = $(datadir)/applications
mate_screenshot_in_files = mate-screenshot.desktop.in
mate_screenshot_DATA = $(mate_screenshot_in_files:.desktop.in=.desktop)
+
$(mate_screenshot_DATA): $(mate_screenshot_in_files)
- $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+if USE_NLS
+ $(AM_V_GEN) $(MSGFMT) --desktop --keyword= --keyword=Name --keyword=Comment --keyword=Keywords --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp $< $@
+endif
man_MANS = mate-screenshot.1
@@ -10,7 +30,11 @@ appdatadir = $(datadir)/metainfo
appdata_in_files = mate-screenshot.appdata.xml.in
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
$(appdata_DATA): $(appdata_in_files)
+if USE_NLS
$(AM_V_GEN) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+else
+ $(AM_V_GEN) cp $< $@
+endif
gsettings_SCHEMAS = org.mate.screenshot.gschema.xml
@GSETTINGS_RULES@