summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-11-06 14:42:18 +0300
committermonsta <[email protected]>2016-11-06 14:42:18 +0300
commit65371f53dbb06180b750dad7c19e7bcf0f8651d6 (patch)
tree0b387d0a17207e13ce662da55970c97b50bc55db /configure.ac
parent7dd02941b3647477dfe0cf8177c2eeff8bfe7b84 (diff)
downloadpluma-65371f53dbb06180b750dad7c19e7bcf0f8651d6.tar.bz2
pluma-65371f53dbb06180b750dad7c19e7bcf0f8651d6.tar.xz
drop Python plugins support and --enable-python build option
it requires PyGTK so won't even build with GTK+3 but keep plugins themselves for future porting to libpeas
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac132
1 files changed, 0 insertions, 132 deletions
diff --git a/configure.ac b/configure.ac
index ba1656a1..112fdd3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,123 +204,6 @@ dnl ================================================================
GLIB_GSETTINGS
dnl ================================================================
-dnl Python
-dnl ================================================================
-
-AC_MSG_CHECKING([whether Python support is requested])
-AC_ARG_ENABLE([python],
- AS_HELP_STRING([--enable-python],[Enable python support]),
- [enable_python=$enableval have_python=$enableval],
- [enable_python=autodetect have_python=yes])
-AC_MSG_RESULT([$enable_python])
-
-if test "x$have_python" != "xno"; then
- AM_PATH_PYTHON([2.5],[],[no])
- if test "x$PYTHON" = "x:"; then
- have_python=no
- fi
-fi
-
-if test "x$have_python" != "xno"; then
- AM_CHECK_PYTHON_HEADERS([],[have_python=no])
-fi
-
-if test "x$have_python" != "xno"; then
- PY_EXEC_PREFIX=`$PYTHON -c 'import sys ; print sys.exec_prefix'`
- PYTHON_LIBS="-lpython$PYTHON_VERSION"
-
- PY_PREFIX=`$PYTHON -c 'import sys ; print sys.prefix'`
- PYTHON_LIB_LOC="-L$libdir/python$PYTHON_VERSION/config"
- PYTHON_CFLAGS="-I$PY_PREFIX/include/python$PYTHON_VERSION"
- PYTHON_MAKEFILE="$libdir/python$PYTHON_VERSION/config/Makefile"
- PYTHON_BASEMODLIBS=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_OTHER_LIBS=`sed -n -e 's/^LIBS=\(.*\)/\1/p' $PYTHON_MAKEFILE`
- PYTHON_EXTRA_LIBS="$PYTHON_BASEMODLIBS $PYTHON_OTHER_LIBS"
-
- AC_SUBST([PYTHON_LIBS])
- AC_SUBST([PYTHON_LIB_LOC])
- AC_SUBST([PYTHON_CFLAGS])
- AC_SUBST([PYTHON_EXTRA_LIBS])
-fi
-
-if test "x$have_python" != "xyes"; then
- if test "x$enable_python" = "xyes"; then
- AC_MSG_ERROR([Python not found])
- elif test "x$enable_python" = "xautodetect"; then
- enable_python=no
- AC_MSG_WARN([Python not found, disabling python support])
- fi
-fi
-
-if test "x$have_python" != "xno"; then
- PYGOBJECT_REQUIRED=2.15.4
- PYGTK_REQUIRED=2.12.0
- PYGTKSOURCEVIEW_REQUIRED=2.9.2
-
- PKG_CHECK_MODULES([PYGTK], [
- pygobject-2.0 >= $PYGOBJECT_REQUIRED
- pygtk-2.0 >= $PYGTK_REQUIRED
- pygtksourceview-2.0 >= $PYGTKSOURCEVIEW_REQUIRED],
- [],
- [
- have_python=no
- if test "x$enable_python" = "xyes"; then
- AC_MSG_ERROR([$PYGTK_PKG_ERRORS])
- elif test "x$enable_python" = "xautodetect"; then
- enable_python=no
- AC_MSG_WARN([$PYGTK_PKG_ERRORS])
- AC_MSG_WARN([Disabling python support])
- fi
- ])
-fi
-
-if test "x$have_python" != "xno"; then
- AC_MSG_CHECKING([for pygtk defs])
- PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
- AC_MSG_RESULT([$PYGTK_DEFSDIR])
-
- AC_MSG_CHECKING([for pygobject defs])
- PYGOBJECT_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygobject-2.0`
- AC_MSG_RESULT([$PYGOBJECT_DEFSDIR])
-
- AC_MSG_CHECKING([for pygtk codegen])
- PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
- AC_MSG_RESULT([$PYGTK_CODEGEN])
-
- AC_MSG_CHECKING([for pygtk h2def])
- PYGTK_H2DEF="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/h2def.py"
- AC_MSG_RESULT([$PYGTK_H2DEF])
-
- AC_SUBST([PYGTK_DEFSDIR])
- AC_SUBST([PYGOBJECT_DEFSDIR])
- AC_SUBST([PYGTK_CODEGEN])
- AC_SUBST([PYGTK_H2DEF])
-
- dnl Check for -fno-strict-aliasing
- FLAGS="-fno-strict-aliasing"
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $FLAGS"
- AC_MSG_CHECKING([whether [$]CC understands $FLAGS])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],[compiler_has_option=yes],[compiler_has_option=no])
- CFLAGS="$save_CFLAGS"
- AC_MSG_RESULT($compiler_has_option)
- if test $compiler_has_option = yes; then
- NO_STRICT_ALIASING_CFLAGS="$FLAGS"
- fi
- AC_SUBST([NO_STRICT_ALIASING_CFLAGS])
-fi
-
-if test "x$have_python" != "xno" -a "x$enable_python" != "xno"; then
- enable_python=yes
- AC_DEFINE([ENABLE_PYTHON],[1],[Define to compile with python support])
-fi
-
-AM_CONDITIONAL([ENABLE_PYTHON],[test "x$enable_python" = "xyes"])
-
-dnl This allows the bug-report script to know whether python has been enabled
-AC_SUBST(enable_python)
-
-dnl ================================================================
dnl Misc
dnl ================================================================
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
@@ -380,26 +263,12 @@ help/Makefile
pixmaps/Makefile
plugin-loaders/Makefile
plugin-loaders/c/Makefile
-plugin-loaders/python/Makefile
-plugin-loaders/python/bindings/Makefile
plugins/Makefile
plugins/changecase/Makefile
plugins/docinfo/Makefile
-plugins/externaltools/data/Makefile
-plugins/externaltools/Makefile
-plugins/externaltools/scripts/Makefile
-plugins/externaltools/tools/Makefile
plugins/filebrowser/Makefile
plugins/filebrowser/org.mate.pluma.plugins.filebrowser.gschema.xml
plugins/modelines/Makefile
-plugins/pythonconsole/Makefile
-plugins/pythonconsole/pythonconsole/Makefile
-plugins/quickopen/Makefile
-plugins/quickopen/quickopen/Makefile
-plugins/snippets/data/lang/Makefile
-plugins/snippets/data/Makefile
-plugins/snippets/Makefile
-plugins/snippets/snippets/Makefile
plugins/sort/Makefile
plugins/spell/Makefile
plugins/spell/org.mate.pluma.plugins.spell.gschema.xml
@@ -420,7 +289,6 @@ Configuration:
Source code location: ${srcdir}
Compiler: ${CC}
GTK API version: $GTK_API_VERSION
- Python Plugins Support: $enable_python
Spell Plugin enabled: $enable_enchant
Gvfs metadata enabled: $enable_gvfs_metadata
Tests enabled: $enable_tests