summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-12-01 14:18:33 +0300
committermonsta <[email protected]>2016-12-01 14:18:33 +0300
commita4dcd9177a32626929783b3920d660782d89bf01 (patch)
tree14ff25db71978942a5e15d1ee60fbb75f493ccff /configure.ac
parent346618b16b111afcb8687d301e344e229ce7fa0c (diff)
downloadpluma-a4dcd9177a32626929783b3920d660782d89bf01.tar.bz2
pluma-a4dcd9177a32626929783b3920d660782d89bf01.tar.xz
build GObject introspection data
mostly adapted from eom and from this upstream commit: https://git.gnome.org/browse/gedit/commit/?id=58921206b7dea94d0ec0359dc43de94745f2a19e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7024575a..6757c498 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,6 +175,16 @@ PKG_CHECK_MODULES(EGG_SMCLIENT, [sm >= 1.0.0])
AC_SUBST(EGG_SMCLIENT_CFLAGS)
AC_SUBST(EGG_SMCLIENT_LIBS)
+# Introspection
+GOBJECT_INTROSPECTION_CHECK([0.9.3])
+
+if test "$found_introspection" = "yes"; then
+ have_introspection=yes
+ AC_DEFINE([HAVE_INTROSPECTION], [1], [Define to enable GObject Introspection])
+else
+ have_introspection=no
+fi
+
dnl ================================================================
dnl GSettings related settings
dnl ================================================================
@@ -268,6 +278,7 @@ Configuration:
Compiler: ${CC}
Spell Plugin enabled: $enable_enchant
Gvfs metadata enabled: $enable_gvfs_metadata
+ GObject Introspection: ${have_introspection}
Tests enabled: $enable_tests
"