summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormonsta <[email protected]>2015-09-29 13:38:04 +0300
committermonsta <[email protected]>2015-09-29 13:38:04 +0300
commite39f5b99d14fcddbd295e2d792980a11b379b1f7 (patch)
tree476eef204936c6a84e50d2894d8dccd8bc6dcbd8 /configure.ac
parentab4da31e0815c8c7931c7075d7b7c54c6666106e (diff)
downloadpluma-e39f5b99d14fcddbd295e2d792980a11b379b1f7.tar.bz2
pluma-e39f5b99d14fcddbd295e2d792980a11b379b1f7.tar.xz
added --enable-tests option which will be off during distcheck
as we have document-saver test failing always
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 641389a3..b786a4fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,6 +353,13 @@ if test "x$enable_deprecations" = "xyes"; then
AC_SUBST(DISABLE_DEPRECATED_CFLAGS)
fi
+AC_ARG_ENABLE([tests],
+ AS_HELP_STRING([--enable-tests], [Enable the tests]),
+ [enable_tests=$enableval],
+ [enable_tests=yes])
+
+AM_CONDITIONAL(ENABLE_TESTS, test x$enable_tests = xyes)
+
PLUGIN_LIBTOOL_FLAGS="-module -avoid-version"
LOADER_LIBTOOL_FLAGS="-module -avoid-version"
@@ -425,6 +432,7 @@ Configuration:
Python Plugins Support: $enable_python
Spell Plugin enabled: $enable_enchant
Gvfs metadata enabled: $enable_gvfs_metadata
+ Tests enabled: $enable_tests
"
if expr ${PLUMA_MINOR_VERSION} % 2 > /dev/null; then