summaryrefslogtreecommitdiff
path: root/plugins/modelines/Makefile.am
diff options
context:
space:
mode:
authormonsta <[email protected]>2016-12-05 17:36:57 +0300
committermonsta <[email protected]>2016-12-05 17:36:57 +0300
commite1fbe56adf49a5f4d3a3bb493933d9ae5a5c081f (patch)
treedb922a4aa29bfabf5572e44e334e23c19af3641c /plugins/modelines/Makefile.am
parentce25be232024458af2a28f4cf145d8cd22f2db29 (diff)
downloadpluma-e1fbe56adf49a5f4d3a3bb493933d9ae5a5c081f.tar.bz2
pluma-e1fbe56adf49a5f4d3a3bb493933d9ae5a5c081f.tar.xz
plugins: make them actually recognized and loaded by Pluma
- use *.plugin extension instead of *.pluma-plugin - use "Plugin" section name instead of "Pluma Plugin" mostly adapted from: https://git.gnome.org/browse/gedit/commit/?id=1d56b827f14096891bb03dbd5e8211fdad1331ad https://git.gnome.org/browse/gedit/commit/?id=7c22769d73f756b9d1388febd147c9d267ed54cb
Diffstat (limited to 'plugins/modelines/Makefile.am')
-rw-r--r--plugins/modelines/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/modelines/Makefile.am b/plugins/modelines/Makefile.am
index e375c898..c4840177 100644
--- a/plugins/modelines/Makefile.am
+++ b/plugins/modelines/Makefile.am
@@ -22,10 +22,10 @@ libmodelines_la_SOURCES = \
libmodelines_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
libmodelines_la_LIBADD = $(PLUMA_LIBS)
-plugin_in_files = modelines.pluma-plugin.desktop.in
-%.pluma-plugin: %.pluma-plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+plugin_in_files = modelines.plugin.desktop.in
+%.plugin: %.plugin.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-plugin_DATA = $(plugin_in_files:.pluma-plugin.desktop.in=.pluma-plugin)
+plugin_DATA = $(plugin_in_files:.plugin.desktop.in=.plugin)
EXTRA_DIST = \
$(plugin_in_files) \